Skip to Content
avatar image
Former Member

Publisher will not refresh reports

Using CR XI r2 , When I try to open publish to Crystal reports I recieve an error message that says it cannot find a installed copy of CR , so it does not refresh or run reports. Any help would be appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Sep 18, 2008 at 09:20 PM

    Hi Steven

    Please confirm:

    Are you attempting to publish a crystal report file (*.rpt) using the Desktop Publisher (downloaded from crystalreports.com) to crystalreports.com space (CRDC a SAAS product) and you are seeing an issue that it cannot find an installed copy of CR?

    OR

    Are you attempting to publish a report using Crystal Reports (the designer) to crystalreports.com (CRDC a SAAS product)?

    A couple of additional questions:

    1. Did the desktop publisher ever work?

    2. Does the local account used in the desktop publisher have permission rights to launch CR XI R2?

    3. What OS, patch level and is it a 32-bit or 64-bit application?

    4. What version of Crystal Reports XI R2 are you using? What patch level?

    5. Are you using a Free Edition or Professional Edition of Crystalreports.com? (SAAS product, not the report designer.)

    6. What is the defualt installation drive for the CR designer and Desktop Publisher?

    Thanks,

    Mario

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 18, 2008 at 09:40 PM

    Mario

    attempting to publish a report using Crystal Reports (the designer) to crystalreports.com (CRDC a SAAS product)?

    Yes it did work .

    I have admin rights, I am usin Windows 2003 server small business SP2 ,CR XI r2 no patches, Pro edition all are installed on the C drive. Thanks You

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Steven,

      The desktop publisher tool needs to be installed on the same machine as your copy of CR.

      Assuming you have actually done this, I have seen a couple cases where the CR sdk (which is what the desktop publisher really needs) is not registered properly so the desktop publisher ends up thinking that it is not installed. This usually happens when CR 2008 has been installed and then uninstalled from the same machine, but it has happened at other times as well.

      You can try a repair install of CR 11.5, but I don't think it actually fixes this problem. You will probably need to uninstall CR and then re-install it (along with whichever service packs you need).

      Cheers,

      Steve