Skip to Content
0

HANA XSA di-core crashes

Apr 09 at 10:51 AM

148

avatar image

Hi,

HANA Version: 2.00.022.00.1511184640

Type: HANA Express (binary installer)

system RAM: 64GB

I am trying to build and run some apps in HANA XSA using web-ide. From today morning di-core app is crashing as soon as I start web ide because of "Out of memory error". Below are the logs.

I tried Increasing xs controller heap size to 512Mb but it did not help.

Can anyone tell how to increase the in-build SAP apps (like di-core, webide etc.) memory limit?

Default memory of di-core is 256M, maybe increasing it might resolve the issue

Thanks

4/9/18 9:51:31.000 AM [RTR] OUT    147.204.149.151 - - to hec01v037420.rot.hec.sap.biz:51020 "GET /project/workspacewg8xqoliggu5fvc8/children/CORE/COREjs HTTP/1.1" 200 sent 378 in 122 by 00H-d809f0d6-1b67-42b9-90a9-27d6e2800531
4/9/18 9:51:37.000 AM [RTR] OUT    147.204.149.151 - - to hec01v037420.rot.hec.sap.biz:51020 "GET /project/workspacewg8xqoliggu5fvc8/tree/CORE?depth=1000∈cludeFiles=true HTTP/1.1" - sent - in - by 00H-d809f0d6-1b67-42b9-90a9-27d6e2800531
4/9/18 9:51:37.445 AM [APP/7-2] ERR    #
4/9/18 9:51:37.445 AM [APP/7-2] ERR    # java.lang.OutOfMemoryError: GC overhead limit exceeded
4/9/18 9:51:37.445 AM [APP/7-2] ERR    # -XX:OnOutOfMemoryError="META-INF/.sap_java_buildpack/sapjvm/bin/killjava.sh"
4/9/18 9:51:37.445 AM [APP/7-2] ERR    #   Executing /bin/sh -c "META-INF/.sap_java_buildpack/sapjvm/bin/killjava.sh"...
4/9/18 9:51:37.480 AM [APP/7-2] ERR    Stopping VM due to OutOfMemoryError
4/9/18 9:51:37.482 AM [APP/7-2] ERR    "http-nio-127.0.0.1-50042-exec-5" #97 daemon prio=5 os_prio=0 cpu=11140.00 [reset 11140.00] ms elapsed=153.50 [reset 153.50] s allocated=3017768144 B (2.81 GB) [reset 3017768144 B (2.81 GB)] defined_classes=111
4/9/18 9:51:37.482 AM [APP/7-2] ERR    io= file i/o: 172658/886 B, net i/o: 31394/14284 B, files opened:0, socks opened:1  [reset file i/o: 172658/886 B, net i/o: 31394/14284 B, files opened:0, socks opened:1 ]
4/9/18 9:51:37.482 AM [APP/7-2] ERR    tid=0x00007f65f24e0800 nid=0x5ebc / 24252  pthread-id=140070356809472 runnable  [_thread_in_vm (_running), stack(0x00007f64abd3a000,0x00007f64abdc8000)] [0x00007f64abdc3000]
4/9/18 9:51:37.482 AM [APP/7-2] ERR       java.lang.Thread.State: RUNNABLE
4/9/18 9:51:37.482 AM [APP/7-2] ERR     at org.eclipse.che.api.project.server.dto.DtoServerImpls$TreeElementImpl.ensureChildren()V(DtoServerImpls.java:8745)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Lucia Subatin
Apr 09 at 04:03 PM
1

Hi,

Upgrading Web IDE and scaling both di-core and di-runner solved that problem for me in the past. Steps here: https://blogs.sap.com/2018/03/09/upgrading-web-ide-in-hana-express/

It's based on rev23 because the download manager had the pointer to the upgrade file, but you will have no problem accessing the mtars.

You can also just scale those two services from the XSA Admin Cockpit, but I would recommend upgrading as there are some improvements around the timeouts in Web IDE that fix a similar behavior.

Best,

Lucia.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

hi Lucia,

For now I have scaled the apps and everything is fine for now.Will upgrade later.

I have a few questions for you:

1) How can we set proxy for HANA XSA after installation (we did not set proxy while installation)

2) As Hana 2.0 Sp3 is here, is it possible to upgrade just the XS runtime, Web-ide and maybe xs-controller only to the latest sp3 version? If it is possible, is it recommended as some components might be dependent on each other internally?

Thanks,

Himanshu

0

Please open separate questions for that so that the community can benefit from them too and we keep this in an organized manner.

However, I would encourage you to be more explicit on what you are trying to achieve in number 2 with updating only some services. If you are referring to applications (Web IDE, Cockpit, etc), that is possible with some restrictions and the note is mentioned in the blog post i quoted in the my answer

0