Skip to Content
0

Save Planning Buffer Disabled - BW - IP / PAK

Apr 09 at 11:46 AM

101

avatar image
Former Member

Hello All,

I am experiencing a scenario like this.

When I execute a planning function manually via RSPLAN on in-memory, I get the application log saying "New records generated". But, I am unable to save the data to the planning cube as the button "Save Planning Buffer" is disabled/greyed out.

Kindly help with some insights.

Regards,

Vinoth V

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Maria Ruseva Apr 11 at 09:17 AM
1

Do you have the problem for all functions or just in one case?

I had the same, but it turned out that despite the green message new records were just not created. There was a problem with the function (arithmetic exception). After solving it, the Planning Buffer appeared again.

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Maria,

Thank you so much for your response.

It is happening only with the planning function in question. Other functions are working fine. When you say Arithmetic exception, may I know how did you manage to locate the issue?

Regards,

Vinoth V

0

Yes, it was because we were changing on BW on HANA and the planning engine in HANA does not allow division by zero, so in the FOX formula we should put check if keyfigure>0. By me the problem was that even by only one problematic record, no new records were created at all, but there was green message display-planning-sequence.jpg

0
Former Member
Maria Ruseva

Thank You so much Maria.

I see your point. But, in my planning function the fox code has got no line where I do any arithmetic operations.

I do have a Time variables TMVL syntax in the code and I am just trying to copy data from actuals cube to Plan cube for two keyfgures. In that case, I am not sure what is causing the issue that disables the planning buffer button.

But, I will try to place a line still saying "If KF > 0" in the code and see. I will update you with the result.

0
Former Member
Former Member

Hi Maria,

Keeping the line "If KF >0" did not help. Working on debugging the code. I will update once the issue is fixed.

Regards,

Vinoth V

0