Skip to Content
avatar image
Former Member

SPROXY not recognizing new Service Interfaces

Hi all,

We are currently on SAP_BASIS 7.0 connecting to XI 3.0 on SP18. I have created a new inbound asynchronous message interface within XI and want to create a server proxy on the SAP side to consume the message from XI. When I execute the SPROXY transaction to import the XI message interface, it is not displayed under the service interface and not allowing me to generate this. Existing proxies exist under other service interfaces created since the upgrade but it doesn't seem to recognize that I created a new message interface in XI. Would this be a compatibility issue with SAP_BASIS 7.0/ECC6 to XI 3.0 SP18 or would do I need to refresh something? Any help would be appreciated.

Thanks,

Nate

Edited by: Nathan Jabs on Sep 17, 2008 6:43 PM

Edited by: Nathan Jabs on Sep 17, 2008 6:44 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Sep 18, 2008 at 07:04 AM

    1.Recreate the name space with other name else than sap.com

    2. check whether ur namespace is displayed in light Grey Color

    then there may be connection to SAP XI issue.

    yes if it is in Light gray colour, you will get a status message as "NO CONNECTION TO INTEGRATION BUILDER (ONLY GENERIC DATA VISIBLE)

    check whether the proxy objects are created under seperate package

    check this help link

    http://help.sap.com/saphelp_nw04/helpdata/en/2b/f49b21674e8c44940bb3beafd83d5c/content.htm

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 17, 2008 at 04:47 PM

    Ask your basis people to check the connectivity between Xi and ECC6. They are compatible. No issues.

    VJ

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 18, 2008 at 07:08 AM

    . Create RFC destination (TCP/IP) LCRSAPRFC and SAPSLDAPI for the SLD connection.

    This must be created , check that that above are working properly....

    Check the below below weblog also

    How do you activate ABAP Proxies?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 18, 2008 at 02:02 PM

    Thank you for the quick responses. The issue was with the namespace, when I took off the sap.com from the namespace in XI and ran SPROXY on our ERP system it recognized the new XI message interface and I was able to create a proxy off it.

    Add comment
    10|10000 characters needed characters exceeded