Skip to Content

Change the language attribute in smartform

I have taken the standard german smartform for the purchasing order, copied it and adjust it to our requirements.

Now I want to copy the smartform in another one and would like to change the language to English. Note! I do not want to translate it , I would like to change all the texts myself in the copied smartform. This woudt't be a problem. The Problem is that the smartform language is DE and I can't change this option even I open the smartform in edit mode. I also can't copy the german smartform in english one, because this copying option doesn't exist.

Does anybody have an idea how to solve this problem?

Kind Regards

Alexey

Add a comment
10|10000 characters needed characters exceeded

Related questions

8 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 22, 2008 at 01:25 PM

    Hi,

    Another clue which might help you is to check the option in the Form Attributes of the smartform as 'Do not translate'.

    Then use all the text elements with language as 'CONTROL_PARAMETERS-LANGU' in the smartform.

    Moreover, make sure that the text elements are created in all the relevant languages required.

    This will ensure depending on the language the relevant standard texts would be displayed on the output.

    Regards,

    Ram

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 19, 2008 at 12:04 PM

    use se63 to provide ur own translation

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 17, 2008 at 03:20 PM

    Login in DE language and while copying make Source language as DE and Target language as EN.

    Add a comment
    10|10000 characters needed characters exceeded

    • There is no possibility (at least in my SAP-Client) to change set source and target language. I have written theis in my first message (I also can't copy the german smartform in english one, because this copying option doesn't exist.)

      I have logged in with the English language and was trying to copy the German smartform . Then SAP tells that this smartform is in German and even I would like to copy it in English. Then it works.

      Now I have logged with German and was trying to open the smartform. It comes the message even I would like to keep English. I have answered "Yes" and the language was changed to EN

  • author's profile photo Former Member
    Former Member
    Posted on Sep 19, 2008 at 09:30 AM

    hi,

    your system need to support both languages like DE, EN, JA etc.insatll both languages are in control panel

    other wise

    ask to basis people.

    Add a comment
    10|10000 characters needed characters exceeded

    • I haven't understood what do You mean under languages in control panel. As I have written (I have logged in with the English language ...Now I have logged with German ...) I can log in different languages.

      The problem I had is actually that we send the purchase orders in diffirent countries an need at least English and German PO smartforms. The byers have fixed that the long text in positions doesn't appear when the vendor's communication language is set to English.

      As I could fix - the selection of position's text is set to &SY-LANGU& which is always D(eutsch) if one logges in German. I have to programm a routine which detects the language based on the field SPRAS from vendor's LFA1-table. Now it works.

      I guess this is an error in the standard /SMB40/MMPO_** smartforms from SAP.

  • author's profile photo Former Member
    Former Member
    Posted on Sep 22, 2008 at 01:07 PM

    As far as I know the smartform language is intrinsic to the language. That is whatever language you login

    that will be the login language.

    Why dont you make a copy of ur DE version and give a different name. And use it for your English version.

    Attach it to a diffrent output type and control it.

    That way u can control the both the versions

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 22, 2008 at 01:31 PM

    Hi,

    Another thing is that you first change to the option 'Translate to all languages ' and then save and activate it.

    Then come out of the edit mode.

    Then again enter into edit mode then it should ask you whether you want to maintain in original language.

    Select for the english mode and then change the option to 'Do not translate' .

    Then do the things as mentioned in my earlier reply.

    Hope this solves your problem.

    Regards,

    Ram

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 23, 2008 at 09:03 AM

    Hi

    once u copy the standard po application in ur own form (then goto header---change language ---then give present langiage (ge) then give the target laun(en) copy (i think u can solve )

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 23, 2008 at 12:03 PM

    Thanx a lot for all comments. I guess this thread could be interesting for internationalisation which is not proper documented even in SAP-Books.

    I would appretiate if smbd. could systematically describe "translate" and "access" attributes in Language Attributes on smartform.

    Kind Regards

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.