Skip to Content
avatar image
Former Member

Custom properties are not enforced when uploading documents with webservice

Hi all

I have created some custom properties (which are mandatory) and assigned them repoistory /documents/abc.

When i manually upload the document through KM upload view , It is prompting for the properties.

Without mentioning these properties, I couldn't be able to upload the document.

but when i upload the document through Repository Framework Web Service (createDocument) without supplying some properties (which are mandatory) also, the document is uploaded to the repository.Why it is not errored out when some properties are not supplied from webservice.

Could you please advice me what i should do to enforce the properties when uploading a document from webservices and custom devoloped applications too.

Thanks,

Karthik.

Edited by: karthik c on Sep 17, 2008 3:54 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Sep 17, 2008 at 02:05 PM

    Hi Karthik,

    The problem comes from the fact, that the settings (mandatory etc) are primarily resolved on the UI level, as you already have observed. It may be discussed if this should be done on a lower level, so that for example WebDAV access, WebService APIs etc also respect these settings.

    For the mandatory setting, as a workaround, you could implement a repository service which checks (also generically) if all properties which are mandatory at the place a document is created / uploaded has got instances of these properties. But keep in mind that you won't get back a error message on the WebService layer - you just could delete the freshly created resource.

    Apart from this workaround, you still may discuss with SAP by opening an OSS message if the implemented behaviour shouldn't be considered as buggy...

    Hope it helps

    Detlev

    Add comment
    10|10000 characters needed characters exceeded