Skip to Content
author's profile photo Former Member
Former Member

Portal SSO between to applications / servers

Hello,

I have the following szenario. We have two application.

The first application is a bsp-application integrated into portal via iView and SSO between portal is working correctly. This application runs on application server one.

The second application is a Dynpro of a workitem called from the UWL and displayed in the UWL as webgui. Here SSO is working correctly too.

Now I have the following situation. The webgui application has a link to an application in the bsp-application. This application is called as an PopUp. But in this case I get a logon prompt, so the SSO2 cookie in the browser is not recognized. Do I have to add parameters to the link, or what do I need to do?

Thanks and regards.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 17, 2008 at 10:57 AM

    Hi,

    Try using the FQDN [Fully qualified domain name] instead of the IP address in the system object.

    E.g. max-sap30:8000

    Hope this will solve your problem.

    Thanks,

    Regards,

    Aditya Metukul

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 17, 2008 at 03:19 PM

    Hi Sebastian,

    I hope you have couple of BSP Applications in Portal. if so when executing the application from portal is it showing logon screen for that too.

    And in UWL, how did you include the BSP application to the task.

    to supress the login for the applications like BSP and WebDynpro for ABAP you need to set a parameter to do so

    in ECC System go to RZ11 -> login/password_change_for_SSO -> Change the ProfileVal and Current Value to 0, by default it will be 1.

    Hope this solves the issue.

    Cheers-

    Pramod

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Sebastian,

      how are you calling your bsp application, ie what does the url look like from your sapgui dynpro interface? Alot of the times, you might need to include the full portal pcd location in your url. There some documentation on help.sap.com on calling a portal iview via a url.

      Cheers,

      Dion

  • author's profile photo Former Member
    Former Member
    Posted on Jul 06, 2010 at 10:21 AM

    We used the wrong full qualified hostname, which was not defined in the SSO relationship.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.