Skip to Content
0

Job fails when doing a change data provider for a second time.

Apr 09 at 07:38 AM

27

avatar image
Former Member

Hi everyone,


I have a small question which i can't find anywhere else. When we do a change dataprovider in the webi universe and we change the universe that it's in ( from test to production for example ) it goes wel 1 time, when we try a second time it crashes the WebIntelligenceProcessingServer service. When we reboot it, it works again for 1 job and then crashes again.


I suspect some kind of caching issue, but the cache isn't full.

What im looking for are some trouble shoot options or links to a usefull notes that descripe the problem.

We are running

SAP BusinessObjects BI Platform 4.2 Support Pack 4 Patch 3
Version: 14.2.4.2545

But the problem already existed in earlier version of BO.

Any kind of information is welcome. If you have some question i will do my best to answer them.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Denis Konovalov
Apr 09 at 12:03 PM
0

could you please describe the workflow in more/better details, as it is not clear what you're doing exactly and how.
Few screenshots might be useful as well.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 11 at 07:22 AM
0

Hi Denis,


I will try but I’m not really sure what more i can tell you.

We have an environment that has 4 different "stages", an develop, test, acceptance and finally a production stage. Whenever we try to "promote" a webireport for example we copy the file over to another stage. We also change the database it connects to. This is ( for as far as i know ) called "Change data provider". Whenever we try to do the "Change data provider" job, it crashes the WebIntelligenceProcessingServer service. When we restart the service, it runs well for 1 job, and at the second job it crashes again.

My suspicion is the that the WebIntelligenceProcessingServer service doesn't have enough resources to run the job twice in a row.

I hope this made the workflow a little more clear, sorry for some bad sentences but I’m not really familiar in this field.

If you need anything else please ask.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 11 at 11:19 AM
0

We fixed the problem by creating another WebintelligenceProccesingServer. It seems the reports we were promoting just were too heavy to be handled by one service.

For now we see this as a quick and dirty fix, but until a consult can look at it, it will have to do.

Share
10 |10000 characters needed characters left characters exceeded