Skip to Content
avatar image
Former Member

Facing issue while encrypt the data using partner PGP public key in HCI

Hi All,

I am facing issue while using partner public key to encrypt the data in HCI.

My 1st requirement is - I have to send file from HCI to another SFTP location (on cloud) after encryption with Partner PGP public key. I have followed below steps-

1. Open a port in HCI tenant for Cloud partner

2. Upload Known_host file in artifacts

3. Copy the content of Partner public key and paste it in pubring.gpg file and upload it in Security material

4. use the PGPEncryptor function in iflow and provide the UserKayID, I fetch this ID from GPA tool after upload the Partner public key. Here I am not using signing

Now while running the scenario, it is failing while encryption and showing error - public key not found corresponding to given KEYID.

Please let me know, if these above steps are correct or any other step need to followed.

2nd Requirement - Sender partner will send the encrypted file to HCI, in this case, I have to send the our public key to partner to encrypt the file. In this case, I have followed below steps-

1. I have generated the key pair using Keystore Explorer and save it with .jks extension and then upload in key store

2. Export the private key from KeyStore Explorer, and save it with openssl format, then load it in putty gen and get the corresponding public key. This key is openssh key but partner requires open PGP key.

So can you please suggest here, what necessary steps needs to be taken.

Many Thanks in Advance.

Ankur

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

0 Answers