Skip to Content
avatar image
Former Member

Error 1935. An error occurred during the installation of assembly...

I utilizing VS.Net and I'm deploying a project to my client machines. The XP client machines execute the code just fine but I get two general errors when I try to run the app on a Vista Business machine.

1) Crystal Reports Basic Runtime for Visual Studio 2008

Error 1935. An error occurred during the installation of assembly.

'Microsoft.VC90.ATL.version="9.0.21009.1.publicKey="1fc8b9a1e18e3b:.processorArchitecture="x86".type="win32'"

Please refer to Help and Support for more information.

2) The other error happens when I actually run the app and its in InnerException error.

Things that I found on the web discuss adding merge modules to VS but I can't find where to reference that info. Are there any other ideas out there.

Thanks-

JLN

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Sep 15, 2008 at 09:18 PM

    Looks like 1935 is a common error on Vista - for all kinds of software, including MS. perhaps the best place to start is with this MS kbase:

    http://support.microsoft.com/kb/926804

    For the above, you are essentially looking at the .NET framework; is it there? Is it of the correct version? Does it need to be repaired?

    The 'Microsoft.VC90.ATL.version=";... error, see if this post helps:

    http://groups.google.com/group/microsoft.public.windows.vista.installation_setup/browse_thread/thread/157a7f18588bda7c

    For the above, looks like you're looking at some sort of Vista SP issue. However, I wonder how you get to the second error? E.G.; how do you get past the 1st error?

    Also, you may want to see if disabling DEP will help. See this post on how to disable DEP on a Vista OS:

    Crystal Reports XI R2 Appcrash in Vista but OK in XP

    Ludek

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Ludek Uher

      Well I got rather frustrated and called Microsoft for a free consultation. After talking it out with the Rep is noticed that the error code I was getting while trying to run my vb.net app as the same error code I got when I tried to launch Windows Update. I researched the error code and found a website (http://www.technipages.com/error-code-8007000b-during-windows-update.html). I followed their instructions with the following code u2013 u201Cfsutil resource setautoreset true c:\u201D. Once I did that I was able to install the Service Pack and that in turned fixed my original problem with an app utilizing Crystal Reports. You could now consider this case closed.

      Thanks-

      Jeff Nichols

  • avatar image
    Former Member
    Sep 20, 2010 at 03:41 AM

    Hello,

    Good Day!

    I'm having a nasty problem that remains unresolved for the last four weeks now - I'm trying to install CR2008 on a brand new Dell laptop /w 64-bit OS Windows 7 with a T4300 dual core processor (2.1Gz). As far as I can see SP1 or SP2 are not installed. However, I see MS WSE 2.0 SP3 Runtime installed.

    During installation of CR 2008 the error message as follows shows up -

    Error 1935: An error occured during the installation of assembly component {303994BA-6487-47AE-AF1D-7AF6088EEBDB}

    HRESULT: 0X80070002

    As a result of this error the installation terminates and the rollback begins (I assume it completely removes the components that it attempted to install so far.

    The laptop has the following significant software applications -

    Microsoft SQL server 2005, SQL server Native Client, MS VisualBasic 2005 & 2008, C++, MS Visual Studio 2005 Remote Debugger & Windows SDK for Visual Studio 2008 - just in case there are any known conflicts or problems.

    Are there any 'leads' I can follow to successfully conclude this installation.

    Thanks for your time.

    TGupta

    Add comment
    10|10000 characters needed characters exceeded