Skip to Content
avatar image
Former Member

interface for function module is incorrect in ALE inbound processing

I have created a custom function module and i assign this FM

to the custom process code for ALE INBOUND process and i already assigned this Fm to message type and basictype in Tcode we57.i have assigned this process code to the msgtype in WE20 also.

But while trying to execute the inbound function module through WE19, I get an error message: "interface for the function module is incorrect". What could be wrong?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Sep 12, 2008 at 06:28 AM

    Hi

    if you ibserve clearly all the FM's will be having same parameters. Your function module also should contain same interface. Ensure that your FM does contain the same.

    *" IMPORTING

    *" VALUE(INPUT_METHOD) LIKE BDWFAP_PAR-INPUTMETHD

    *" VALUE(MASS_PROCESSING) LIKE BDWFAP_PAR-MASS_PROC

    *" EXPORTING

    *" VALUE(WORKFLOW_RESULT) LIKE BDWF_PARAM-RESULT

    *" VALUE(APPLICATION_VARIABLE) LIKE BDWF_PARAM-APPL_VAR

    *" VALUE(IN_UPDATE_TASK) LIKE BDWFAP_PAR-UPDATETASK

    *" VALUE(CALL_TRANSACTION_DONE) LIKE BDWFAP_PAR-CALLTRANS

    *" TABLES

    *" IDOC_CONTRL STRUCTURE EDIDC

    *" IDOC_DATA STRUCTURE EDIDD

    *" IDOC_STATUS STRUCTURE BDIDOCSTAT

    *" RETURN_VARIABLES STRUCTURE BDWFRETVAR

    *" SERIALIZATION_INFO STRUCTURE BDI_SER

    *" EXCEPTIONS

    *" WRONG_FUNCTION_CALLED

    Add comment
    10|10000 characters needed characters exceeded