Skip to Content
Former Member
Sep 11, 2008 at 08:18 PM

Archiving using Process Chain, writes to archive but doesn't delete data


I have created an Archiving Process for a cube, and set it up to automatically start the "delete". I then created a process chain to execute the Archiving Process.

When I execute the process chain, here's what I notice in the joblogs:

1) Archiving job runs, writing the selected data to archive file

2) A separate deletion job is started, but the deletion job runs in "test" mode (which seems kind of like simulation mode) and identifies the records it would delete but it never actually deletes the data from the cube.

3) In SARA (Archive Administration), this run shows up as an "Incomplete Archiving Session", showing that archiving step was complete but deletion hasn't occured.

I am able to delete the data by running the "Delete" manually in SARA and then the "Archiving Session" goes to "completed" status. When I run it manually from SARA, the job log shows that it is running in "production mode" and not "test mode".

My question is... Is there a way to start the deletion in "production mode" and not "test mode" when I run the process chain?

Or is this a bug, that I should report to OSS?

Thanks much.