Skip to Content
author's profile photo Former Member
Former Member

WIH00013 - Invalid Session

When VIEWing a Webi report in BO XI 3.0 in InfoView if I leave it open for more then 20 minutes and I click on "Refresh Data" I get an error message that says "Invalid Session" error WIH00013.

I have modified the session timeout in web.xml file for the InfoView app and the web.xml file in the CMC app to be 60 minutes instead of the default 20 minutes, restarted the servers (both BO and Tomcat) and even modified the Webi server setting "Idle Connection Timeout (minutes)" from the default 20 to 60 minutes. And restarted that too.

Nothing seems to affect it.

Any ideas?

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    Posted on Sep 11, 2008 at 12:15 PM

    Try editing web.xml files in Analyticalreporting.war and InfoviewAppActions.war files and make session timeout the same as in Infoviewapp.war.

    Redeploy war files and restart your App server after that.

    In case of tomcat, you can just edit those web.xml files in /webapps/.... directories.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Erika,

      not yet till now.

      but you can try to set the session-timeout to 60 minutes in each of the war file InfoviewApp, InfoviewApp Actions, Platform Services inside webapps folder.


      it's almost 1 year since the problem happened 😔..



  • author's profile photo Former Member
    Former Member
    Posted on Sep 17, 2008 at 07:54 PM

    For what it's worth we ran into the same problem. Then I found this white paper from BO/SAP which describes how session managment works in BO XI 3.0.

    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/000c1adc-5d56-2b10-7f99-94be28cf3480

    It says to make sure and modify all web apps deployed for BO XI 3.0 to use the same timeout value.

    -George

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 21, 2009 at 03:33 PM

    Hi ALL

    We are in BOXIR2 environment.

    When I run the WebI report after 2 minutes , I am getting the

    Error : Invalid session. Please close your browser and log on again (WIH 00013),

    Can anyone please help me providing me with the solution.

    Appreciated ur help.

    Thanks

    Kumar

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi all,

      I also face a similar issue with a SunOne Application server setup. It's a cluster setup and we have not enabled session persistence. When we access the webI report and try to refresh it from about 20 sessions from 5 clients, on all sessions within a second we will get the invalid session error.

      thanks,

      Krishna

  • Posted on Apr 01, 2015 at 08:00 PM

    Invalid session. Please close your browser and login again. (WIH 00013)

    Error occurring when I open a WebI report and go to 2nd or last page of that report. I am able to refresh the report and save it without any issues. Also the same report is working fine in Production. I have imported that report from Prod to test but still it is behaving the same.

    The connection time out was already 60 mins (some of the blogs recommended)

    Every other report from the same universe it belongs is working fine.

    Our Application server is Websphere and we are using BO XI 3.1. Do I have to make any web.xml war files? How do I do it in websphere app server?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.