Skip to Content

Unable to fetch system in GRC access request

Hello All,

I am unable to fetch the system in access request form. In the form I click on Add - > System. I should get the list of systems that are maintained in the settings in SPRO. I have maintained the systems in the integration scenarios such as PROV etc.

We are currently on GRC 10.1 SP15.

Request you to help me out with this.

Thanks in advance !

Best Regards,

Praman Mulay

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Apr 04 at 02:52 PM

    Hi Praman,

    I faced this issue with GRC 10.1 SP18, and it was caused by a missing authorization object that is newly introduced in 10.1. The object was GRAC_SYSTM. Also check to see that GRAC_SYS is also assigned.


    Hope this helps,

    Ken

    Add comment
    10|10000 characters needed characters exceeded

    • Next I would reproduce the error in non-prod, then assign SAP_ALL to your account and see if the systems become available thereafter. If they become available, then you know there's a missing authorization. If not, then it is likely configuration or data synchronization issue. Complete the full repository object sync and authorization syncs again.

  • Apr 06 at 04:13 AM

    It seems to be a configuration in SPRO configuration , maybe you are missing a step when maintaining the connection groups, scenarios or sub scenarios

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Praman,

      Go to method GET_AUTH_CONNECTORS class CL_GRAC_ACCESS_REQUEST_UTIL, in line 29 the system tries to get the connector, in this method the system will check scenarios specific authorizations and more, the table from the system is taken is grfnconnscnlk,

      I hope that this can be helpfull,

      Regards

      Rafael

  • Apr 06 at 06:20 PM

    Param,

    Do you have any LDAP as the Datasource,if so can you check if you have access to the S_LDAP with ACTVT 51,03 and also for Auth Object GRAC_REQ do you have field : GRAC_RQFOR with M,O,S

    Thanks

    Ramesh

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 07 at 08:44 AM

    Hello,

    Please ensure you maintain the connectors in SPRO --> IMG --> GRC --> Access Control --> Maintain Connector Settings.

    Let me know if that works.

    Vandana

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 07 at 08:07 AM

    Hi

    Make sure that connector you have configured in SPRO have Active box "Checked".

    Shivam

    Add comment
    10|10000 characters needed characters exceeded