Skip to Content
0

Unable to fetch system in GRC access request

Apr 04 at 02:40 PM

84

avatar image

Hello All,

I am unable to fetch the system in access request form. In the form I click on Add - > System. I should get the list of systems that are maintained in the settings in SPRO. I have maintained the systems in the integration scenarios such as PROV etc.

We are currently on GRC 10.1 SP15.

Request you to help me out with this.

Thanks in advance !

Best Regards,

Praman Mulay

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Ken Golden Apr 04 at 02:52 PM
0

Hi Praman,

I faced this issue with GRC 10.1 SP18, and it was caused by a missing authorization object that is newly introduced in 10.1. The object was GRAC_SYSTM. Also check to see that GRAC_SYS is also assigned.


Hope this helps,

Ken

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Ken,

Thanks for your reply. I have complete access to the authorization objects GRAC_SYSTM and GRAC_SYS. Am I missing some thing else ? Please let me know should you require more information.

Regards,

Praman Mulay

0

Next I would reproduce the error in non-prod, then assign SAP_ALL to your account and see if the systems become available thereafter. If they become available, then you know there's a missing authorization. If not, then it is likely configuration or data synchronization issue. Complete the full repository object sync and authorization syncs again.

0
Rafael Guimbala
Apr 06 at 04:13 AM
0

It seems to be a configuration in SPRO configuration , maybe you are missing a step when maintaining the connection groups, scenarios or sub scenarios

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Rafael,

Thanks ! I got the configuration set up checked by couple of people as well. We did not miss out on any configuration. I just wanted to know if we are able to fetch the roles then why are we not able to see the systems.

Best Regards,

Praman Mulay

0

Hi Praman,

Go to method GET_AUTH_CONNECTORS class CL_GRAC_ACCESS_REQUEST_UTIL, in line 29 the system tries to get the connector, in this method the system will check scenarios specific authorizations and more, the table from the system is taken is grfnconnscnlk,

I hope that this can be helpfull,

Regards

Rafael

0
Ramesh Vithanala Apr 06 at 06:20 PM
0

Param,

Do you have any LDAP as the Datasource,if so can you check if you have access to the S_LDAP with ACTVT 51,03 and also for Auth Object GRAC_REQ do you have field : GRAC_RQFOR with M,O,S

Thanks

Ramesh

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Ramesh,

Thanks for your reply. The access is present already (We have the complete access). Any other thing I am missing.

Thank you !

Regards,

Praman Mulay

0

Hi Praman,

To eliminate the authorization issue, can you do the same by assign full access(GRAC_ALL & SAP_ALL).

Thanks

Ramesh

0
Vandana Maini
Apr 07 at 08:44 AM
0

Hello,

Please ensure you maintain the connectors in SPRO --> IMG --> GRC --> Access Control --> Maintain Connector Settings.

Let me know if that works.

Vandana

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Vandana,

Thanks for your reply. We have already maintained the connectors in connector settings.

Best Regards,

Praman Mulay

0
Shivam Agarwal Jun 07 at 08:07 AM
0

Hi

Make sure that connector you have configured in SPRO have Active box "Checked".

Shivam

Share
10 |10000 characters needed characters left characters exceeded