Skip to Content
avatar image
Former Member

RAISE_BINDING_EXCEPTION

Hi Guru's,

Here I have a situation... getting the Exception while trying to display a View using WDA. I have a Component Controller Context Node. with Cardinality 0..1 and selection 0..1 and copied and mapped to View Context. On this load of the application there are no values assigned to the Node. It throws the following expection.

Ecact Error Note :

The following error text was processed in the system NEW : Adapter error in &VIEW_ELEMENT_TYPE& "TXV_NAME" of view "/APPLICATION.V_ASSIGN_TECH_ASSIST": Context binding of property TEXT cannot be resolved: Node COMPONENTCONTROLLER.1.HOME_PAGE.1.CHANGING_1.1.PC_ALTER_DELE_1 does not contain any elements

The termination type was: RABAX_STATE

The ABAP call stack was:

Method: RAISE_FOR of program CX_WDR_ADAPTER_EXCEPTION======CP

Method: RAISE_BINDING_EXCEPTION of program CL_WDR_VIEW_ELEMENT_ADAPTER===CP

Method: GET_BOUND_ELEMENT of program CL_WDR_VIEW_ELEMENT_ADAPTER===CP

Please help me in resolving getting this fixed. The requirement is I need to display the View even if there are no values in the Contex Node.

Thanks

Ketan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Sep 09, 2008 at 01:23 PM

    Hi Ketan ,

    Does some attributes of the node is binded to view elements like input field or something ,as they need atleast one node element to be present means cardinality 1..1.

    Regards

    Yash

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      The problem is the context attribute is coming from FM. So i do have the attribute listed under the FM.CHANGING NODE.Attribute1 this is how it is listed in the COMPONENT CONTROLLER. So how do you want me to proceed on this?

      Thanks

      Ketan