Skip to Content

Unable to run the customized MAU application

Hi All,

I am working on ZMAU application which is the customer enhancement of standard MAU30 aplication.

when I am trying to run the application, I am getting " HTTP 404 - File not found"

These are the steps I am following:-

1. Generated the war file from NWDS with this option.

a. Add JSP as compiled classes.

b. Delete generated Java files after .war has been generated.

2. Deployment in MI admin was sucessful, but when I run the application, It gives "File not found error".

Later I checked the MI folder, ZMAU.jar file is created in the lib directory with all the class files

So its like the application is trying to search http://localhost:port numver /ZMAU/start

which according to web.xml is

- <servlet-mapping>

<servlet-name>mam_0005fstart</servlet-name>

<url-pattern>start</url-pattern>

</servlet-mapping>

and now the jsp file is included in the jar file as a compile class.

Can any one suggest me a way so that I can run the application.

Thanks and Regards

Neha Mahanty

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Sep 08, 2008 at 07:13 PM

    Hi,

    could have several possible problems. Well, sometimes MAM has a problem when you change the name form AMM to zMAM. this should be solved in your version but it was problematic in the first versions. So please try the MAM30 naming while creating the file. Furthermore the name while creating the WAR file and uploading it to the Webconsole and downloading it from there to the device for deployment - all these names MUST match.

    Then: you said you have deleted the generated WAR files. Keep them for reference and check if create was a success. Even if you get errors in JSP creatin, you will not see any error message in the console. If JSP compilation fails, the file is there - but it is empty. Check if the JAVA file created out of the JSP has code in it.

    Well, these are the normal things I can tell you based on your description.

    What I always do: I deploy the not changed app to my device - if this works fine, then I start with the Z-Coding and simply deploy the WAR file locally over the existing WAR folder. The working WAR folder I keep for reference with the name: MAM30_original. It is really simple: after you deployed the original MAM file and it worked fine, rename its folder in Webapps to MAM_original. Then run the build process of your z-App and name this file as well MAM30. So the MAM30.war is generated inside the WEBAPPS folder. then restart your MI and you get a new MAM30 folder, beside the existing MAM30_original one. Now you should be able to start the changed app without issues. If this does not wrk, then yu have an isue with the coding.

    Well, it works the samen way for MAU or any other Smartsync app, simply change the name.

    Hope it helps!

    Regards,

    Oliver

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Oliver,

      Thanks for the information.

      I run the application by selecting the option " Keep generated java files in project after .war file has been created".

      *And yes the $JSP folder is empty. Also the folder

      WEB-INF\classes folder is empty, ie no .class files are present*

      Also the tools.jar file is present.

      Now atleast this is clear that the error is coming coz the .class fiels are not there

      Please guide how to proceed, so that the .class files are getting generated there.

      Thanks and Regards

      Neha Mahanty