Skip to Content
0

Different result in model segmentation vs. Infoset Query

Mar 29 at 02:50 PM

65

avatar image
Former Member

Hi all,

please, why my results may be different between Infoset Query vs. Segmentation model (with the same input). TREX job was succesfully processed in CRMD_MKTDS t-code...what to check? What to set up? I have cases where the numbers are the same and when not...an example when not:

Well, if I try create filter for transaction ID, which is missing e.g 5695604, I can see BP (reverse method is not problem, data are available in model for this...)

sq01-01.png (12.8 kB)
sq01-02.png (4.8 kB)
sq01-03.png (24.9 kB)
sq01-04.png (21.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Kevin Wang
Apr 05 at 08:34 AM
1

Hello Zdenek,

I suppose you could consider to set BP at the call-stack provided in "debug Infoset" part, and check why the result is different:

https://wiki.scn.sap.com/wiki/display/CRM/Segmentation+in+CRM+Marketing

Kind regards,

Kevin

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Dear Kevin, thank you for your reply. It's still a mystery to me...after running a TREX update (crmd_mktds) I can see a query process in SM50...so I jumped on it and debugged it. When debugger was started, I setup a watchpoint for my BP example. It stopped, but only for 2 records (should be for twelve ID)...but anyway, after this - there are 5 records in the Web-UI...I don't understand it, why...an example of my debugging:

If I create Z report for SELECT with db cursor (like in segmentation) I get 12 records in lt_dataset...it's between heaven and earth. :(

Zdeněk

debugg01.png (81.1 kB)
debugg02.png (30.7 kB)
0
Former Member
Former Member

Today I deep debugged this case...I founded in segmentation processing then output %dtab contains ALL my 12x RECS for case BP....I blame charts in WebUI segmentation that don't display results correctly...I have no other explanation for this.

Zdenek

zmkt05.png (189.5 kB)
0

Hello Zdenek,

Would you please consider to report a OSS incident in CRM-MKT-SEG component? Then I could login your system to identify the root cause.

Thanks and Kind regards,

Kevin

0