Skip to Content
avatar image
Former Member

SAP AFARIA SP27 - Incorrect app version distributed

We use AFARIA SP27 for iOS device management

In our pre-production environment we are using a static group with a pull [app optional policy]. The administrator is also pushing the app to target devices as required. For some reason the older and not latest version of the app is pushed.

When we switch the policy to push [app = required] the correct version is pushed. When using dynamic groups with a pull policy the correct application version is distributed.

Has anyone else experienced this issue


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Mar 29 at 04:10 PM

    Hi Wasif,

    I am assuming you are using Afaria enterprise client on these devices. Can you check for optional app policies, the app list on the Afaria iOS client on the device if the app is showing up under the "Updates" section? Was this application deployed via MDM the first time? Did you try soft resetign device and try again?. I would also check the following tables to make sure updated app is listed with correct version( I assume it is since it is working in different scenarios):

    A_INV_IPHONE_APPS Version column and compare to the content of the column Contentversion in A_PRFL_PACKAGE_CONTENT

    Also if you provision a new device or reprovision an existing one do you see same issue?

    I hope this help. Let me know if you have any follow up questions.

    Thank you

    Aziz

    Add comment
    10|10000 characters needed characters exceeded