Skip to Content

Adapter engine error

All our outbound messages are getting stuck in Adapter engine message monitoring as system error status

Error category :XI_J2EE_ADAPTER_XI_HANDLER

Error code :GENERAL_ERROR

I would appreciate all your help and suggestion to resolve this error

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 05, 2008 at 09:27 AM

    Hi,

    think the problem is in the structure of the xml you want to send. I mean, that the structure of the message you are sending by means of SOAP adapter is not the same that the structure in the Inegration Repository.

    When you test your message with a wrong BS it is sent to the IE and you can see this message in sxmb_moni with error status. It`s obvius, there is no configuration for this scenario. However if you test your scenario with right parametes but the content (xml structure) is wrong, the step when the content of the call is converted to the structure of the IR will fail. And the message doesn`t get the IE.

    So check the content of your call.

    Check with this

    How to deal with stuck EOIO messages in the XI 3.0 Adapter Framework

    Follow this Blog to Send the Message through RWB--IE

    https://blogs.sap.com/?p=41006

    I hope it is useful for you.

    Regards,

    Jayasimha jangam

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 05, 2008 at 09:14 AM

    Moved to XI forum.

    Regards

    Juan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 05, 2008 at 09:17 AM

    Hi,

    Refresh adapter engine,if problem is not solve restart it will work. Some time it will happend due to error message stuck in queue.

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 05, 2008 at 09:28 AM

    What receiver adapter are you using?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 05, 2008 at 09:39 AM

    Hi Daneil,

    clear the message in queues smq1,smq2 (or) try to resend the data from message monitoring

    Regards,

    skumar

    Add comment
    10|10000 characters needed characters exceeded