Skip to Content
avatar image
Former Member

Data Transfer Prozess stops, but no error message (huge amount of data)

Hello Experts,

Sometimes I have a problem with the Data Transfer Process by loading up huge amount of data from PSA to the Cube. There is no error message or something like that. You can only see in the DTP-Monitor, that the last step of some data packages are yellow and the system is not longer working on this request.

The symptom only appears by huge amount of data (CO-PA..)

Thank you for your help

Florian

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Sep 04, 2008 at 11:20 AM

    Hi Florian,

    did you already check st22 and/or sm21 for error during the process? Do so and let us know.

    regards

    Siggi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you for your answer Siggi!

      Yes, of cause I have checked the syslog and abap short dumps.

      An error occurs only when I set the request status to red. (Dead log .. SQL error)

      But when I do nothing the request monitor shows always the yellow state (No Message: Updating to InfoCube "NAME") and the processor of the system do nothing.

      Flo

  • avatar image
    Former Member
    Sep 04, 2008 at 11:45 AM

    Hi,

    Did you check in SM58 and see if there are some failures in RFC.

    It is possible tha in the the case of huge data loads RFC failures occur.

    you can also check the job log in SM37 and see if there is any ARFC=SysFail..

    If it is happening then you have take it up with the basis.

    May be you will have to increase the area of internal memory!!

    Thanks

    Ajeet

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Now I can see without setting the request to red an error from Abap Processor:

      "ABAP/4 processor: DBIF_RSQL_SQL_ERROR"

      "Job cancelled".

  • avatar image
    Former Member
    Sep 05, 2008 at 10:52 AM

    Hello Florian,

    may be the usual problem of an active index during loading of a datacube. The index maintainance has to recreate the indizes while loading, and it have to do this in parallel if you have more than one data package loading. This may mean deadlock or memory problems.

    Please drop the index of the Cube (Manage->Performance->Delte Index (Now)) and retry your load. Don't forget to rebuild the index after load.

    You can do this in a process chain too.

    Kind regards,

    Jürgen

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Jürgen,

      you are greate! That is the solution!!! 😊

      See also note 84348.

      Thank you all for your help.

      Nice weekend

      Florian