Skip to Content
avatar image
Former Member

TSV_TNEW_PAGE_ALLOC_FAILED

Hi Guys,

The Current System Configuration of my SAP System(ECC 6.0) is

Kernel-- SP Level 133 & Release 700

OS-SUN OS 5.9

DB-Oracle 9.2

FINBASIS 600 0006 SAPK-60006INFINBASIS

When I am executing T-code UCMON with Input value,I am getting dump of TSV_TNEW_PAGE_ALLOC_FAILED alon with the short Text " No more storage space available for extending an internal table."

The Current parameter values are as:-

abap/buffersize 450000 kB

abap/pxa shared

Generic key table buffer TABL

zcsa/table_buffer_area 30000000 Byte

zcsa/db_max_buftab 5000

Single record table buffer TABLP

rtbb/buffer_length 10000 kB

rtbb/max_tables 500

ztta/roll_area 3000000 Byte

ztta/roll_first 1 Byte

ztta/short_area 3200000 Byte

rdisp/ROLL_SHM 16384 8 kB

rdisp/PG_SHM 8192 8 kB

rdisp/PG_LOCAL 150 8 kB

em/initial_size_MB 4092 MB

em/blocksize_KB 4096 kB

em/address_space_MB 4092 MB

ztta/roll_extension 2000000000 Byte

abap/heap_area_dia 2000000000 Byte

abap/heap_area_nondia 2000000000 Byte

abap/heap_area_total 2000000000 Byte

abap/heaplimit 40000000 Byte

abap/use_paging 0

Please suggest the method to resolve the dump and move forward in this case .

Regards

Manoj

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Sep 14, 2008 at 05:43 PM

    Hi manoj jaiswal,

    It will happens when there is no more extended memory available in the server to extend internal table, when this happens you need to check the ST02 in the application server remember ST02 is specific for server. in ST02 you can find the extended memory as given below

    SAP memory Current use Max. use

    [%] [kB] [kB]

    Roll area 0,16 426 30.144

    Paging area 0,02 43 62.544

    Extended Memory 3,03 126.976 221.184

    here the memory utilization is 3%

    keep on monitor this and execute your job when you have free memory or else you can run the on a server where the memory is free. You can also change the parameters by tuning the memory parameters and changing the memory parameters according to the memory availability in your system.

    Regards,

    S.Manu

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 08, 2009 at 03:43 PM

    Hi,

    I have seen in the past that re-running the job, will resolve the error due to TSV_TNEW_PAGE_ALLOC_FAILED. If not, pls run the tcode when the load on the system is less.

    Regards

    Vimal

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 24, 2009 at 06:32 PM

    Manoj,

    With your current parameter, system is able to extend upto 4 GB memory (Extended + Heap) to a user. Generally SAP written program (not Y or Z program) is able to execute within this limit, until unless lot of data is fetched by particular program which is not so common.

    In case SAP standard program is giving this dump, check out if there is some fix available at SAP service marketplace for this transaction to address this particular issue.

    Rgds,

    Mahesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 07, 2009 at 11:28 AM

    Hi Manoj,

    If the problem stil exists you can try with the following values. Hope your issue will be resolved.

    ztta/roll_extension 5368709120 Byte

    abap/heap_area_dia 3221225472 Byte

    abap/heap_area_nondia 3221225472 Byte

    abap/heap_area_total 5368709120 Byte

    let me know if you have any questions.

    Regards

    Praveen

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2009 at 04:19 PM

    Please copy past the whole dump.

    There is a section in the dump :

    "The amount of storage space (in bytes) filled at termination time was:"

    where you can see the memoy usage at runtime

    so you can then determine why the TSV_TNEW_PAGE_ALLOC_FAILED raised :

    because apab/heap_area_dia was exhausted ?

    because apab/heap_area_nondia was exhausted ?

    because apab/heap_area_total was exhausted ?

    because ztta/roll_extension was exhausted ?

    other ....

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      I´m faccing with the same problem during an importing phase XPRA_EXECUTION.

      When I check the error in st22 it show me a dump: TSV_TNEW_PAGE_ALLOC_FAILED

      In the field "Error analysis" it´s shown me this:

      The internal table "AREA=CL_UGMD_META2INSTANCE=UGMD_FIELDINFO_LOCALVERSID=9

      OBJ=DATA=DT_DFIES" could not be

      further extended. To enable

      error handling, the table had to be delete before this log was written.

      As a result, the table is displayed further down or, if you branch to

      the ABAP Debugger, with 0 rows.

      At the time of the termination, the following data was determined for

      the relevant internal table:

      Memory location: "AREA=CL_UGMD_META2INST=UGMD_FIELDINFO_LOCALCLNT="

      Row width: 1342

      Number of rows: 0

      Allocated rows: 1

      Newly requested rows: 3048 (in 381 blocks)

      Any idea? I already had this error in past in other system with exactly the same importing queue and I solved that after I create in instance profile this two parameter:

      abap/buffersize = 450000 (how can I calculate this value...?)

      PHYS_MEMSIZE = 5800 (which is 70% of 8Gb of RAM which is the amount RAM of this server)

      In this particulary case I already tune the system and apply them to instance profile but after I continuing the import from that phase it stops again with the same error, so I realize unfortunately this isn´t work with the same correction!! 😔

      I also check the ST02 and I could see this:

      http://img20.imageshack.us/img20/8706/st02memory.png

      Can you help me please how can I solve this problem?!

      Thank you

      Best regards

      João Dimas - Portugal