Skip to Content
avatar image
Former Member

SDM and Java

Hi All,

I have facing 2 issues,

1. Is there any way to restart the SDM server seperately as I am facing the following problem while login in and while stopping the server.

Shutdown failed: Cannot shutdown server. There are active sessions: Session id 12 / An administrator logged in via GUI / /

Could not shutdown server: Could not shutdown Server(4)

Details: Shutdown failed: Cannot shutdown server. There are active sessions: Session id 12 / An administrator logged in via GUi

Processing error. Return code: 4

2. Also when i start the SDM, it shows the 'Starting /usr/java/bin/java' ' - Xmx256'

I think it is using only 256 Mb of RAM? I have opened configtool and changed the server properties to 512 and heap to 2048, but still the same. Is there any other parameter to change the java setting?

Thanks & regards,

Prashant

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Sep 04, 2008 at 07:37 AM

    Hi,

    You can use the scripts stopserver and startserver to start and stop sdm manually.

    These scripts are located in sdm/program folder.

    Or just try restarting only the java stack using SMICM.

    Regards,

    Vamshi.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 04, 2008 at 10:43 AM

    If possible check the active session nd try to kill it and then restart the server

    Regards

    Faisal

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 04, 2008 at 12:25 PM

    > 1. Is there any way to restart the SDM server seperately as I am facing the following problem while login in and while stopping the server.

    is server is on windows if yes try restarting using mmc

    > 2. Also when i start the SDM, it shows the 'Starting /usr/java/bin/java' ' - Xmx256'

    where did changed this parameter?

    did you restarting SDM after changing this parameter

    Samrat

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 04, 2008 at 09:22 PM

    Hi Prashant,

    To stop and start the SDM I used the following procedure

    cd /usr/sap/<SID>/JC<XX>/SDM/program

    ./StopServer.sh "sdmhome=/usr/sap/<SID>/JC<XX>/SDM/program"

    ./StartServer.sh "sdmhome=/usr/sap/<SID>/JC<XX>/SDM/program"

    to change the password for SDM you can follow the following sequence

    Login as <SID>ADM

    1) cd /usr/sap/<SID>/JC<XX>/SDM/program

    2) ./StopServer.sh "sdmhome=/usr/sap/<SID>/JC<XX>/SDM/program"

    3) ./sdm.sh jstartup "sdmhome=/usr/sap/<SID>/JC<XX>/SDM/program" "mode=standalone"

    4) ./sdm.sh changepassword "sdmhome=/usr/sap/<SID>/JC<XX>/SDM/program" "newpassword=<newpassword>"

    5) ./sdm.sh jstartup "sdmhome=/usr/sap/<SID>/JC<XX>/SDM/program" "mode=integrated"

    6)./StartServer.sh "sdmhome=/usr/sap/<SID>/JC<XX>/SDM/program"

    Thank You

    Reg,

    Kishore

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 15, 2014 at 10:39 AM

    Go to path


    /usr/sap/<SID>/<sysno>/SDM/program

    Stop SDM service

    ./StopServer.sh

    change the mode to standalone

    ./sdm.sh jstartup "mode=standalone"

    change password of your choice

    ./sdm.sh changepassword "newpassword=password"

    change mode to integrated

    ./sdm.sh jstartup "mode=integrated"

    Now your SDM password is changed and started SDM.

    Add comment
    10|10000 characters needed characters exceeded