Skip to Content
avatar image
Former Member

SAP BW query has mandatory variable, but in webi, it's not prompt

Hi,

I have a customer who created a BW query with a mandatory variable. But when he created the webi report and run the query, even he select the variable's object, the prompt is not working unless he select some other key figure.

Here is the definision of the filter in Universe Designer;

The value in the WHERE panel is: <FILTER KEY="[ZTDISTSM]"><CONDITION

OPERATORCONDITION="Equal"><CONSTANT TECH_NAME="@Prompt('District

(Single, Mand)','A','DISTRICT\Lov[ZTDISTSM]

Base',mono,primary_key)"/></CONDITION></FILTER>

Please help if you have any idea.

thanks and regards

nora

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Sep 14, 2008 at 11:11 AM

    "To process BW variables in Web Intelligence, you must include at least one measure in the Web Intelligence query."

    Quoted from SAP olap universe guide page 44.

    Regards,

    Adil

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 16, 2008 at 10:47 AM

    hi Nora,

    is this XIr2 or XIr3 ?

    Ingo

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 17, 2008 at 01:25 AM

    Hi Adil,

    Thanks for your info as yes, once customer select one measure, the prompt will work.

    And Ingo, the version is XIR2.

    thanks and regards

    nora

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 22, 2008 at 06:12 AM

    To use atleast one measure has resolved the issue.

    Add comment
    10|10000 characters needed characters exceeded