Skip to Content
avatar image
Former Member

Mixed (Java & ABAP w/different sources) System Copy Failed- NW 7.0 SR3/SP14

Hello SAP Friends! Our NW admin did a dual stack system copy where the ABAP server came from system 1 and the Java server came from system 2. This worked fine for ABAP (duh it was installed first), but the Java system copy was a disaster. the server started but many key services did not.

Why?

Many of the configuration entries were not generated properly. For example, a new, unknown SID was created, and many entries referenced System 1 (the ABAP source, not even the Java source). We were able to find and fix some incorrect config entries, but we still couldn't get all of the services we needed to work.

I think NW is so complicated that such a configuration is probably impossible, but maybe I am wrong.

Does anyone have tips? Or can confirm that this would never work?

The current plan is to install the Java Server from scratch as an add-in, which is less effort than searching through all the config files without any certainty that it will work. 😊 Hopefully it will work.

Many thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Sep 03, 2008 at 11:34 PM

    Hi John,

    How was the copy performed?

    Best Regards,

    Matt

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi John,

      First I must say that I do not know if your "different sources" will work. But what I'm trying to find out is how the copies were performed in the first place. Were they done as a backup/restore, or a DB export/import using SAP tools (as described in the System Copy Guide)? I ask this since a backup/restore will not work on Java, no matter what the source, and some of the problems you are describing occur when this method is attemped.

      Best Regards,

      Matt