Skip to Content
avatar image
Former Member

ALV in EDIT-Mode: can't hide the toolbar in edit-mode

Hi,

I have supressed in my ALV all standard-buttons with the help of an it_toolbar_excluding. I have built my own toolbar (p_object->mt_toolbar). Until know everything is fine, the ALV shows only my own generated toolbar.

In that moment, when I change a property of a column in the fieldcatalog ( wa_catalog-edit = 'X' ), both toolbars are shown, the standard toolbar and my own generated buttons.

What's wrong, how can I hide the standard toolbar when I am in the edit mode?

Kind regards

Andreas

Edited by: Andreas Waldt on Sep 3, 2008 5:19 PM

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Sep 03, 2008 at 03:28 PM

    you can use this and hide the standard tool bar

    layout-NO_ROWINS = 'X'.

    and also you disable all the FUnctions using the exclude option. if not check it once.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you very much,

      during testing I have recognized, that the buttons in the toolbar are new functions, because of the edit mode.

      So I have put all the new button into the excluding list. It worked!

      Thanks again!

      Andreas