Skip to Content
avatar image
Former Member

TNS-03505 Failed to Resolve Hostname

Guys I am having trouble with a NW2004s installation. I am getting the following error when I do a TNSPING of my listener (LISTENER_DC1)

TNS Ping Utility for IBM/AIX RISC System/6000: Version 10.2.0.2.0 - Production o

n 03-SEP-2008 08:35:19

Copyright (c) 1997, 2005, Oracle. All rights reserved.

Used parameter files:

/oracle/DC1/102_64/network/admin/sqlnet.ora

TNS-03505: Failed to resolve name

p15913dtp220:oradc1> ^C

p15913dtp220:oradc1> ^C

p15913dtp220:oradc1>

Here is my sqlnet.ora file

p15913dtp220:oradc1> cat sqlnet.ora

################

  1. Filename......: sqlnet.ora

  2. Created.......: created by SAP AG, R/3 Rel. >= 6.10

  3. Name..........:

  4. Date..........:

  5. @(#) $Id: //bc/700-1_REL/src/ins/SAPINST/impl/tpls/ora/ind/SQLNET.ORA#4 $

################

AUTOMATIC_IPC = ON

TRACE_LEVEL_CLIENT = OFF

NAMES.DEFAULT_DOMAIN = WORLD

  1. 05.01.06 unsorported parameter now

#NAME.DEFAULT_ZONE = WORLD

  1. 05.01.06 set the default to 10

SQLNET.EXPIRE_TIME = 10

  1. 05.01.06 set to default

#TCP.NODELAY=YES

  1. 05.01.06 set to 32768

DEFAULT_SDU_SIZE=32768

This is my TNSNAMES.ORA file

  1. Filename......: tnsnames.ora

  2. Created.......: created by SAP AG, R/3 Rel. >= 6.10

  3. Name..........:

  4. Date..........:

  5. @(#) $Id: //bc/700-1_REL/src/ins/SAPINST/impl/tpls/ora/ind/TNSNAMES.ORA#4 $

################

DC1.WORLD =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS =

(COMMUNITY = SAP.WORLD)

(PROTOCOL = TCP)

(HOST = sapdbdc1-sv)

(PORT = 1539)

)

)

(CONNECT_DATA =

(SID = DC1)

(GLOBAL_NAME = DC1.WORLD)

)

)

This is my Listener.ora file

################

  1. Filename......: listener.ora

  2. Created.......: created by SAP AG, R/3 Rel. >= 6.10

  3. Name..........:

  4. Date..........:

  5. @(#) $Id: //bc/700-1_REL/src/ins/SAPINST/impl/tpls/ora/ind/LISTENER.ORA#4

################

ADMIN_RESTRICTIONS_LISTENER_DC1 = on

LISTENER_DC1 =

(ADDRESS_LIST =

(ADDRESS =

(PROTOCOL = IPC)

(KEY = DC1.WORLD)

)

(ADDRESS=

(PROTOCOL = IPC)

(KEY = DC1)

)

(ADDRESS =

(COMMUNITY = SAP.WORLD)

(PROTOCOL = TCP)

(HOST = sapdbdc1-sv)

(PORT = 1539)

)

)

STARTUP_WAIT_TIME_LISTENER_DC1 = 0

CONNECT_TIMEOUT_LISTENER_DC1 = 10

TRACE_LEVEL_LISTENER_DC1 = OFF

SID_LIST_LISTENER_DC1 =

(SID_LIST =

(SID_DESC =

(SID_NAME = DC1)

(ORACLE_HOME = /oracle/DC1/102_64)

)

(SID_DESC =

(SID_NAME = DC1)

(ORACLE_HOME = /oracle/DC1/102_64)

)

)

Any help much appreciated !!

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 04, 2008 at 03:29 PM

    This is the clue

    4 ETW000 [dev trc ,00000] Closing user session (con_hdl=0,svchp=0x110f934b

    8,usrhp=0x110f928c0)

    4 ETW000

    236 0.080567

    4 ETW000 [dev trc ,00000] Now I'm disconnected from ORACLE

    502 0.081069

    4 ETW000 [dev trc ,00000] Try to connect with default password

    35 0.081104

    4 ETW000 [dev trc ,00000] Connecting as SAPR3/<pwd>@DC1 on connection 0 (n

    ls_hdl 0) ... (dbsl 700 110706)

    4 ETW000

    42 0.081146

    4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet

    C EnvHp ErrHp ErrHpBatch

    4 ETW000

    44 0.081190

    4 ETW000 [dev trc ,00000] 0 UTF8

    1 0x110f8aae0 0x110fa2f58 0x110fa2808

    4 ETW000

    45 0.081235

    4 ETW000 [dev trc ,00000] Assigning username to user session 0x110f928c0

    26 0.081261

    4 ETW000 [dev trc ,00000] Assigning password to user session 0x110f928c0

    33 0.081294

    4 ETW000 [dev trc ,00000] Starting user session (con_hdl=0,svchp=0x110f934

    b8,srvhp=0x110fa5278,usrhp=0x110f928c0)

    4 ETW000

    67 0.081361

    4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCISessionBegin' failed:

    rc = 1017

    4 ETW000

    2353 0.083714

    4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '1017

    '

    4 ETW000

    43 0.083757

    4 ETW000 [dblink ,00431] ***LOG BY2=>sql error 1017 performing CON [dbl

    ink#3 @ 431]

    4 ETW000

    187 0.083944

    4 ETW000 [dblink ,00431] ***LOG BY0=>ORA-01017: invalid username/password

    ; logon denied [dblink#3 @ 431]

    4 ETW000

    42 0.083986

    2EETW169 no connect possible: "DBMS = ORACLE --- dbs_o

    ra_tnsname = 'DC1'"

    p15910dtp214:dc1adm>

    Cheers

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 03, 2008 at 10:31 AM

    Read SAP Note 443867 - ORA-12154 Collective SAP note

    Regards

    Juan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 03, 2008 at 02:40 PM

    Nick,

    To bolster a bit Juan's response - this note is the place to start. Two things come to mind here (1) Do any of your OS level users sidadm, orasid, etc have an "@" symbol in their passwords? I know from experience that the @ symbol can create very serious issues that are difficult to pinpoint. (2) is "sapdbdc1-sv" really the hostname? Again, while not 100%, I try to avoid special characters here. If possible, you could test this scenario by adding a line into the hosts file of the machine to help the Listener resolve correctly. Be sure you can back out the change however in case it causes other issues.

    Cheers,

    Tim

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Cheers I am getting a bit further .....

      Fisrst I can start the database using SQLPLUS

      p15913dtp220:oradc1> sqlplus "/as sysdba"

      SQL*Plus: Release 10.2.0.2.0 - Production on Wed Sep 3 16:27:23 2008

      Copyright (c) 1982, 2005, Oracle. All Rights Reserved.

      Connected to an idle instance.

      SQL> startup

      ORACLE instance started.

      Total System Global Area 4714397696 bytes

      Fixed Size 2083728 bytes

      Variable Size 2365588592 bytes

      Database Buffers 2332033024 bytes

      Redo Buffers 14692352 bytes

      Database mounted.

      Database opened.

      SQL>

      Now as oradc1 I can start the listener

      LSNRCTL> START LISTENER_DC1

      Starting /oracle/DC1/102_64/bin/tnslsnr: please wait...

      TNSLSNR for IBM/AIX RISC System/6000: Version 10.2.0.2.0 - Production

      System parameter file is /oracle/DC1/102_64/network/admin/listener.ora

      Log messages written to /oracle/DC1/102_64/network/log/listener_dc1.log

      Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=DC1.WORLD)))

      Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=DC1)))

      Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=10.127.158.138)(PORT=153

      9)))

      Connecting to (ADDRESS=(PROTOCOL=IPC)(KEY=DC1.WORLD))

      STATUS of the LISTENER

      -


      Alias LISTENER_DC1

      Version TNSLSNR for IBM/AIX RISC System/6000: Version 10.2.0.2

      .0 - Production

      Start Date 03-SEP-2008 16:36:20

      Uptime 0 days 0 hr. 0 min. 0 sec

      Trace Level off

      Security ON: Local OS Authentication

      SNMP ON

      Listener Parameter File /oracle/DC1/102_64/network/admin/listener.ora

      Listener Log File /oracle/DC1/102_64/network/log/listener_dc1.log

      Listening Endpoints Summary...

      (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=DC1.WORLD)))

      (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=DC1)))

      (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=10.127.158.138)(PORT=1539)))

      Services Summary...

      Service "DC1" has 1 instance(s).

      Instance "DC1", status UNKNOWN, has 1 handler(s) for this service...

      The command completed successfully

      And R3trans u2013d works

      p15913dtp220:dc1adm> R3trans -d

      This is R3trans version 6.14 (release 700 - 18.09.06 - 09:35:00).

      unicode enabled version

      R3trans finished (0000).

      BUT when I run startdb u2026

      It just crashes u2026

      p15913dtp220:dc1adm> startdb

      Trying to start DC1 database ...

      Log file: /home/dc1adm/startdb.log

      /usr/sap/DC1/SYS/exe/run/startdb: Terminating with error code 16

      p15913dtp220:dc1adm> more startdb.log

      -


      Wed Sep 3 16:39:14 BST 2008

      LOGFILE FOR STARTING ORACLE

      Trying to start DC1 database ...

      -


      Wed Sep 3 16:39:14 BST 2008

      checking required environment variables

      ORACLE_HOME is >/oracle/DC1/102_64<

      ORACLE_SID is >DC1<

      -


      Wed Sep 3 16:39:14 BST 2008

      check initora

      /usr/sap/DC1/SYS/exe/run/startdb: Terminating with error code 16

      p15913dtp220:dc1adm>

  • avatar image
    Former Member
    Sep 04, 2008 at 08:04 AM

    Whats really puzzleing me is that with user oradc1 R3trans -d doesn't connect and fails with the following .....

    This is R3trans version 6.14 (release 700 - 18.09.06 - 09:35:00).

    unicode enabled version

    2EETW169 no connect possible: "DBMS = ORACLE --- dbs_o

    ra_tnsname = 'DC1'"

    R3trans finished (0012).

    p15913dtp220:oradc1> ^C

    p15913dtp220:oradc1>

    But with dc1adm R3trans connects .....

    p15913dtp220:dc1adm> R3trans -d

    This is R3trans version 6.14 (release 700 - 18.09.06 - 09:35:00).

    unicode enabled version

    R3trans finished (0000).

    Cheers

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Tim,

      OK heres the scenario .......

      I have a unix box (sapdbdc1) on there I have installed the central service (ASCS62)

      The database is copied from another system. The database starts up fine. The listener (LISTENER_DC1) is up and running listening on port 1539. All is good .......

      Now I have another box (sapapdc1) the application server, on here I am installing the a central instance. everything was going fine until the part where the apps server wants to connect to the database. The output from R3trans is

      p15910dtp214:dc1adm> R3trans -d

      This is R3trans version 6.14 (release 700 - 18.09.06 - 09:35:00).

      unicode enabled version

      2EETW169 no connect possible: "DBMS = ORACLE --- dbs_o

      ra_tnsname = 'DC1'"

      R3trans finished (0012).

      So its trying to connect to the oracle instance but can't even see it !!!

      I tries what you suggested, so on the appserver sapapdc1 as dc1adm run brtools and it failed

      p15910dtp214:dc1adm> brtools

      BR0651I BRTOOLS 7.00 (18)

      BR0152E Environment variable ORACLE_HOME is not set

      BR0280I BRTOOLS time stamp: 2008-09-04 16.01.34

      BR0654I BRTOOLS terminated with errors

      I then set the environment variable and it now works

      p15910dtp214:dc1adm> brtools

      BR0651I BRTOOLS 7.00 (18)

      BR0280I BRTOOLS time stamp: 2008-09-04 16.05.19

      BR0656I Choice menu 1 - please make a selection

      -


      BR*Tools main menu

      1 = Instance management

      2 - Space management

      3 - Segment management

      4 - Backup and database copy

      However R3trans -d still does not work

      Cheers fro the help