Skip to Content
avatar image
Former Member

Impossible to set my adobe forms as enable in WD4A

Hi all,

I define an adobe forms which can be used in off-line scenario ( by e-mail ) and on-line by WD4A.

By e-mail there's no problem my forms is enabled and user can modify the content.

IN WD4A , if i set the forms in the UI Elements as enabled then it's not display but if i set it as not enabled it's display.

Does anybody can help me ?

My forms is a ZCI one , i work on ECC 6.0 SP 14 on Abap Stack and SP12 on Java Stack .

Thanks

Edited by: Bertrand DESSERTENNE on Sep 2, 2008 9:15 PM

I'll debug my WD4A application, and in class CL_WD_ADOBE_SERVICES method DETERMINE_DOCPARAM codes forbidden to use Adobe forms as interactive in WD4A if it's based on SAP DDIC ...Somebody can tell me why ?

Edited by: Bertrand DESSERTENNE on Sep 9, 2008 5:19 PM

Hi all,

I'm still working on this problem , after lot of time spend on this i'm able to display my forms as interactive in a WD4A without using an XML Based interface .

Now i got another problem, in standard class CL_WD_ADOBE_SERVICES method Update_pdf is call and in the code i do'nt understand this test :

* do additional things for the DDIC interface type
  if m_interface_type = if_fp_interface=>c_interface_type_new and
     i_fillable = abap_true.
*   possibly, the data xml needs to be resend to the ADS
*   three cases:
*   (1) there are child nodes => fixed for print forms, no reason for them
*   (2) there are dropdowns
*   (3) needs to be sent anyway due to hide_toolbar

*   first, lets find out if there are dropdowns
*   <todo> cache this information!

*   update the data as necessary
    lr_data_source_info = i_data_source->get_node_info( ).
    if execute_ads_call = abap_true or
       lr_data_source_info->get_child_nodes( ) is not initial or
       "vhlist_xml <> '<sap-vhlist></sap-vhlist>'.
       1 = 1.

Can somebody tell me why there is the test 1=1 .....

With this test i lost all my data on the form , if in debug i make the result of this test false everything is ok on my form.

Best regards

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 29, 2008 at 01:43 PM

    I succes to pass value from my WD4A to the form while using "Supply Function". Unfortunately all dynamic text define in the context of the form and all code define in the initialization part of the interface doesn't work ...so i need to transform my form into a XML one's .

    Unfortunately SAP doesn't provide any support on this problem because it's not a XML interface .....

    Add comment
    10|10000 characters needed characters exceeded