Skip to Content
avatar image
Former Member

No authorization to display portal favorites for a standard user

Hi Gurus,

I'm facing the following problem. I have created a standard user in SAP Portal and I 've assigned him the "Everyone" role along with a couple of custom roles.

When I log in the portal with his credentials in the navigation side of the initial page I get the "Access denied" message in the Portal favorite window because he doesn't have the neccessary permissions.

What are the steps that I've missed?

Points available!

Regards,

Panos

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 03, 2008 at 08:34 AM

    Hi Panagiotis,

    Have a look into the Portal Desktop link below.

    http://help.sap.com/saphelp_nw70/helpdata/EN/ac/dc4f3eeb684212e10000000a11405a/frameset.htm

    Somewhere mid section, you will find Portal Favourites (http://help.sap.com/saphelp_nw70/helpdata/EN/3a/d609e5803111d5992f00508b6b8b11/frameset.htm).

    Make sure that Knowledge Management is installed on your system and that you have activated the Add to Portal Favorites property (this entry is displayed in the options menu of your page title bar).

    http://help.sap.com/erp2005_ehp_03/helpdata/EN/84/a30a48887d4cb690b4f1754f651ba1/frameset.htm

    If all above if set, then checkout the needed activities within the Portal Favourite iview setting.

    http://help.sap.com/saphelp_nw70/helpdata/EN/1e/62eae2357c4596bda2476d0a6503e3/frameset.htm

    Checkout on both the page title bar Options menu and the context menu of the Detailed Navigation iView display an Add to Portal Favorites item, allowing users to store links to favorites (thats where I believe your missing permission).

    The Portal Favorites iView is part of the Knowledge Management installation and is integrated into the portal. Thus if the above steps are done and the settings activated, then your standard user should not see error in the Portal Favourites with the role that you have already assigned to the user.

    Also look into Standard User (eu_role), which basic functionality (portal personalization iViews) for the core portal platform and default content for the Knowledge Management and Collaboration capabilities of SAP NetWeaver. By default, the Everyone group in the portal is assigned to this role.

    http://help.sap.com/saphelp_nw70/helpdata/EN/47/f0f7415e639c39e10000000a155106/frameset.htm

    Hope that helps.

    Ray

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 02, 2008 at 03:30 PM

    Hi!

    Did you perform the initial admin tasks as they are outlined in sap help. one part here is setting default permissions. Look here: http://help.sap.com/saphelp_nw70/helpdata/de/46/a660054ad945158e5021155bca3495/content.htm

    Regards,

    Volker

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      HIIIi ..

      Just do one thing Assigned your to Everyone group and then check.

      And also Set Read/write permission of Roles for everyone user group

      Hope it would wrk.

      Thanks

      Regards

      Mayank Kumar Saxena

      Rewrds r welcome

  • avatar image
    Former Member
    Sep 03, 2008 at 09:13 AM

    Thank you all for your usefull answers. Problem solved!

    Regards,

    Panos

    Add comment
    10|10000 characters needed characters exceeded