Skip to Content
author's profile photo
Former Member

XL Reporter

Hi All,

We upgraded to SAP B1 2007 from 2005. Xl reporter is running well on some machines. For others no data is being displayed after generating the report. Kindly assist on how to solve this. Thank you.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    author's profile photo
    Former Member
    Sep 10, 2008 at 04:39 AM

    Database structure and tables have some changes between 2005 and 2007 version especially in financial module. That might be the main reason some of XL Reports stop working.

    The best solution would be modify those reports to make them work again. Please post any report names to see what kind of reports have these problem.

    Thanks,

    Gordon

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Sep 02, 2008 at 03:20 PM

    Dear Betty,

    Also please do the following steps :

    Edit the report definition to fit the UDF's after a change to

    the UDF in B1. Update both the selection formula in the Advanced Report

    Builder and the ixdimget in the cell in Excel.

    Regards,

    Rakesh Pati

    SAP Business One Forum Team

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi all,

      My XL Reporter still not working ok after an upgrade from SAP B1 2005 to 2007. After report generation - Report Instance, There are no records displayed. Shows the fields only. Help.

      Thanks.

  • author's profile photo
    Former Member
    Sep 02, 2008 at 09:20 AM

    Hi

    If your reports have any UDF's you will have to make them visible again. In the report composer window - Tools>User Defined Fields.

    Regards

    Daan

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Sep 09, 2008 at 02:20 PM

    Hello,

    I have a client with exactly the same issue. They upgraded from SAP B1 2005 to 2007 A. When you create an XL Report you can see values in Report Composer. But when you generate a report, you only get the column headings (Field Names) in the spreadsheet. You do not get any data values. I can duplicate this issue on my test system to some extent. When I create a report in Report Composer and only select a Dimension data item, I get the same result as my client, just column heading and no data values. But, if I add a Light Dimension data item in Report Composer, I can then see data values in the spreadsheet when I generate the report. My client is running SAP B1 2007 PL15. I am running SAP B1 2007 PL30 in my test system. We both are running XL Reporter version 8.0.13. Does anyone have additional information that could solve this issue?

    Edited by: Bill Turek on Sep 9, 2008 8:42 PM

    Edited by: Bill Turek on Sep 9, 2008 8:43 PM

    Add comment
    10|10000 characters needed characters exceeded