Skip to Content
avatar image
Former Member

WebDynpro ABAP iView

Hello experts.. we are creating several iViews for our portal, all these iViews are from WebDynpro, some of them WebDynpro for Java and some others are WebDynpro for ABAP.

I have successfully created all the WebDynpro Java iViews.

Now I need to create the WD Abap iViews for the portal but I'm having some dificulties... first of all, I need the WD Abap iViews to connect the same way the Java ones.. this means the same user/password -WD Java uses- without asking for authentication... in Java we don't have that problem because the connection is handled by te JCo, but now I don't know how to set this up for their ABAP counterpart. Is it possible? to launch the WDA application without asking to logon, and to use in this case the same user we're using with the WD for Java -the one of the JCo-?

The other problem I'm having is when testing the WDA iView, so far I manually type username and password but I'm getting the following error.

Please check the protocol and host entries for system 'DESARROLLO_ECC'..

We're connecting to ECC 6.0, which parameters do I need to set up in order to get it right?

Any guidance or comments will be welcome.

Thanks in advance..

JV

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Sep 02, 2008 at 04:49 AM

    Hi Jesus,

    Try making an SSO logon ticket for your WDA server, and assign it to users that can use the WebDynpro. This way you would not get the logon page while trying to access the WebDynpro.

    Harika

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 02, 2008 at 04:51 AM

    Hi Valencia,

    You will have to configure single sign on (SSO) between the portal system and the system on which you have hosted the WDA applications. This will remove the authentication issue.

    w.r.t the error you facing...do check if the WDA system is reachable from the system where ur trying to access the application, when I say reachable try to ping the WDA system

    Thanks,

    GLM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi GLM,

      I'm trying to create WDA IVIEW in portal , after creating that when I check the preview I'm getting a screen page cannot displayed. (Normal screen when internet explorer doesnt work)

      What would be the cause.SSO was configured and working fine.

      Thanks.

      Bhargav

  • avatar image
    Former Member
    Sep 02, 2008 at 10:18 PM

    Thank you guys.. cheers.

    Solved the exception setting up:

    WAS Host

    WAS Protocol

    On my system in PCD.

    The authentication issue was solved with SSO. Also tried out user mapping and worked out.

    Add comment
    10|10000 characters needed characters exceeded