Skip to Content
avatar image
Former Member

HTTP Error

Hi Everyone,

I am Configuring File to Http.

I am getting Error as

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?> 
- <!--  Call Adapter 
  --> 
- <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="">
  <SAP:Category>XIAdapter</SAP:Category> 
  <SAP:Code area="PLAINHTTP_ADAPTER">ATTRIBUTE_CLIENT</SAP:Code> 
  <SAP:P1>400</SAP:P1> 
  <SAP:P2>ICM_HTTP_CONNECTION_FAILED</SAP:P2> 
  <SAP:P3 /> 
  <SAP:P4 /> 
  <SAP:AdditionalText /> 
  <SAP:ApplicationFaultMessage namespace="" /> 
  <SAP:Stack>HTTP client code 400 reason ICM_HTTP_CONNECTION_FAILED</SAP:Stack> 
  <SAP:Retry>A</SAP:Retry> 
  </SAP:Error>

What is to be done to resolve the Issue.

Regards,

Varun

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 01, 2008 at 11:03 AM

    be sure you have activated plain_adapter service

    Peter

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 11:04 AM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 01:07 PM

    HI

    check this for HTTP errors...

    Http* Errors in XI

    HTTP 403 during cache refresh of the adapter framework - Refer SAP Note -751856

    Note :::804124

    Note :::807000

    Do the following settings to increasing the time_out

    please Increase the HTTP_TIMEOUT parameter value

    1) goto XI ABAP Stack

    2) goto SXMB_ADM

    3) Select Integration Engine---Specific Config

    4) set the parameter HTTP_TIMEOUT to maximum number

    Refer the michales's weblog for the same.

    XI: Timeouts, timeouts, timeouts....

    https://blogs.sap.com/?p=41828

    regards,

    Kishore

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 11:00 AM

    Tcode SICF

    activate services under

    /default_host/sap/xi

    Peter

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 11:01 AM

    Hi,

    Your error code is 400, so check this link,

    http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html

    For hhtp 400, its a bad request,

    'The request could not be understood by the server due to malformed syntax.'

    If you have the xi troble shooting guide see from page 54,and also try,

    1.Check that the port really is the ICM HTTP Port (transaction

    SMICM) and not the J2EE port

    2.If the port is wrong, change the pipeline URL in the SLD in

    the business system of the Integration Server

    3.Restart the J2EE Engine to reset the SLD buffer of the

    Adapter Engine

    Source- "Xi troubleshooting guide"

    or

    1. try question 14 (integration engine section)

    Finally Best of SDN 2005

    2. also question 11 (in the same section)

    3. if the avove will not fix it open xi config guide and

    have a look at section

    "Connecting Business Systems with an Integration Engine to the Central Integration Server"

    did you complete all the steps?

    BTW

    but do the 1,2 steps in the first place:)

    "Award points if helpful"

    Regards,

    Jayasimha Jangam

    Add comment
    10|10000 characters needed characters exceeded