Skip to Content
avatar image
Former Member

Error in Http Receiver adapter.

HI Everyone,

I am doing File to HTTP Scenario.

I am Getting error as "ICM_HTTP_CONNECTION_FAILED" when i check in message monitoring.

What could be the problem.

Regards,

Varun

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 01, 2008 at 07:29 AM

    Hi Varun,

    Check this threads, Its very helpful for ur issue.

    ICM_HTTP_CONNECTION_FAILED

    SAF - ICM_HTTP_CONNECTION_FAILED

    HTTP adapter setup

    Regards,

    NSKumar

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Varun,

      Check whether HTTP receiver adapter configuration is correct and also check if the RFC destination is properly configured.

      Regards

      B.Dheepa

  • Sep 01, 2008 at 07:51 AM

    What is the HTTP Error Status ? i.e. HTTP 401 or 403 etc.Because there can be many reasons for ICM_HTTP_CONNECTION_FAILED.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 07:07 AM

    Hi,

    You need to Activate the HTTP Services in XI

    Goto SICF-Execute-default_host--sapxi---Make sure that You have activated all the Services Under this

    REgards

    Seshagiri

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 07:07 AM

    Go through this blog..

    https://blogs.sap.com/?p=41828

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 07:14 AM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 07:07 AM

    Hi,

    The request could not be understood by the server due to malformed syntax. The client SHOULD NOT

    repeat the request without modifications

    Check the blog..

    [https://www.sdn.sap.com/irj/sdn/weblogs?blog=/pub/wlg/4061] [original link is broken] [original link is broken] [original link is broken];

    Regards,

    Prakasu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 01, 2008 at 11:04 AM

    Hi,

    Your error code is 400, so check this link,

    http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html

    For hhtp 400, its a bad request,

    'The request could not be understood by the server due to malformed syntax.'

    If you have the xi troble shooting guide see from page 54,and also try,

    1.Check that the port really is the ICM HTTP Port (transaction

    SMICM) and not the J2EE port

    2.If the port is wrong, change the pipeline URL in the SLD in

    the business system of the Integration Server

    3.Restart the J2EE Engine to reset the SLD buffer of the

    Adapter Engine

    Source- "Xi troubleshooting guide"

    or

    1. try question 14 (integration engine section)

    Finally Best of SDN 2005

    2. also question 11 (in the same section)

    3. if the avove will not fix it open xi config guide and

    have a look at section

    "Connecting Business Systems with an Integration Engine to the Central Integration Server"

    did you complete all the steps?

    BTW

    but do the 1,2 steps in the first place:)

    "Award points if helpful"

    Regards,

    Jayasimha Jangam

    Add comment
    10|10000 characters needed characters exceeded