Skip to Content
0

"Failed to install native resource: Linux-lib.jar"

Mar 27 at 11:40 AM

181

avatar image

I have installed openSUSE 42.3 as a guest on host MAC OS. Whenever I am installing SAPGUI for JAVA 7.40 rev 12, I get following error:

"Failed to install native resource: Linux-lib.jar"

There is a directory "JDK-10" inside the home directory. Any ideas?

Thanks

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Bartosz Jarkowski Mar 27 at 11:46 AM
0

Most probably you have downloaded incorrect version of SAP GUI. Are you sure you have selected MAC OS on the download page?

2541156 - Failed to install native resource : <Platform>-<Version>S.lib.jar

Show 7 Share
10 |10000 characters needed characters left characters exceeded

Thank you for your response. Yes I have downloaded the correct version as the installation shows successful in Xterm. Thank you.

0

OK, that's great it's working. Please close the question and choose the correct answer that other people can benefit as well.

0

Many apologise Bartosz, it is not working as of yet as I could not find the SAP GUI 7.40 for Linux, where can I find this download? Thanks again :)

0

On which OS are you trying to install the SAP GUI? MacOS or Linux?

0

I am trying to install on Linux

0

I checked SAP Note 2059424 - SAP GUI for Java: Requirements for Release 7.40 and in the requirement list there is

Oracle Java SE 8 32- or 64-bit (update 25 or newer). Please install it and check again - I don't think JDK10 is supported.

0

Ok will give a go, thanks - also which directory do I install the Oracle Java SE 8 32- or 64-bit so that SAP GUI for JAVA 7.40 rev 12 will find it and will not get errors again? Sorry for silly questions as I am a novice, thanks for your patience and advice.

0