Skip to Content

Lumira Navigation Panel Sort Alphabetically

Hello Experts,

I would like to follow up on this question from two years ago: https://archive.sap.com/discussions/thread/3845713

In Lumira Designer 2.1 the Navigation Panel still sorts dimensions as they are listed in Query Designer and not alphabetically as is the default behavior in BEx Web Analyzer. Is there still no way to change this behavior? Maybe through javascript?

Since IdeaPlace is no more, we would like to request this as an option in the properties of the Lumira Navigation Panel. I can't imagine we are the only ones who expect dimensions to be listed alphabetically.

Regards,

Michael

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 10 at 08:21 AM

    Hi Michael,

    in Lumira Designer you are able to sort the navigation panel alphabetically.

    To achieve that, you have to make use of the technical component called Value Help Settings.

    Just focusing on the sorting of dimensions and not the other abilities/use-cases of this component, you have to take the following steps:

    1. Add the technical component Value Help Settings to your application
    2. In the properties of the added component go into the Value Help Settings Items
    3. Next to the "Insert" Button you can see an arrow, click that and choose Add All Other Dimensions
    4. At the bottom left you can see the Runtime Sort Order, choose your desired one

    5. Submit with OK
    6. Go to your navigation panel properties and you can see the Value Help area, there you have to choose your created value help settings

    Regards,

    Adrian

    Add comment
    10|10000 characters needed characters exceeded

    • Thank you Adrian, I had not heard of the Value Help Settings component. Your method of adding All Other Dimensions works for my needs.

      Thanks,
      Michael

  • Apr 12 at 02:18 PM

    Hi Adrian,

    Really good information.

    Actually, in our case we have key figure structure and I want to shot measures available in structure by alphabetical order.

    I tried solution suggested by you but it only works with dimension.

    Following setting I maintained in value help technical component to sort measures,

    In navigation panel following setting is also maintained.

    Do you have any idea about the issue?

    One more issue I am facing in this component,

    When we click down arrow button it shows two options,

    1) Add all other dimension

    2) Measure dimension

    Suppose if I select "Measure dimension" and execute the report it shows measures in measure box but no dimensions in dimension box and vice-versa in navigation panel.

    I am not sure whether it is normal behavior or what?

    Thanks in advance!

    Darshil Shah

    Add comment
    10|10000 characters needed characters exceeded