Skip to Content
author's profile photo Former Member
Former Member

CMC not Launcing, The Page Cannot be Found

Crystal Reports Server XI R2. I am no longer able to open CMC. When I try and launch it I get an error message in I.E. that says "The page cannot be found". Well, the connection string is looking for "admin.cwr" in the /en folder and it's not there. It must have been at one time because I'm using the same connection string. I searched the whole computer for it with no luck.

http://wbsql1/businessobjects/Enterprise115/admin/en/admin.cwr?action=logoff&clgoff=true

CMC will not launch through the Launchpad but Infoviewer will.

This is the connetion string Launchpad generates:

http://wbsql1/businessobjects/Enterprise115/admin/en/admin.cwr

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Aug 28, 2008 at 06:39 PM

    If you enter the following URL in a web brower:

    http://wbsql1/businessobjects/pookie.cwr

    do you get a WCA error message or a 404 error message? Expected is the WCA error message.

    The cwr extension is a virtual, and not physical, file. It may be that the mapping has been lost.

    In IIS Manager, right-clikc on the businessobjects web application, Properties and Configuration... button, then see if the .cwr extension is mapped to the .NET framework DLL. Right-click on the cwr entry, click "Edit" and ensure that the "Verify that file exists" checkbox is not checked.

    Then look in <install>\Web Content\Web.config to see that there's a httpHandlers tag mapping the cwr extension to the WCAHandler class.

    Sincerely,

    Ted Ueda

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi There Ted, I have the same problem with Crystal Reports Server XI R2. When I am in the CMC home page I click on "Authentication" and I get "The page cannot be found" error. I have checked in IIS and the cwr entry is already in there. It is as follows

      C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll

      the "Verify that file exists" is NOT ticked. I looked in the <install>\Web Content\Web.config file and could only find the following section that had httpHandlers.

      <httpHandlers>

      <add verb="*" path="*.csp" type="BusinessObjects.Enterprise.WebComponentAdapter.WCAHandler,BusinessObjects.Enterprise.WCA, Version=11.5.3300.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />

      <add verb="*" path="*.cwr" type="BusinessObjects.Enterprise.WebComponentAdapter.WCAHandler,BusinessObjects.Enterprise.WCA, Version=11.5.3300.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />

      </httpHandlers>

      I guess I am missing the tag that should be there to map the cwr extension to the WCAHandler class as you suggest. I would not know where to begin to fix this Web.config file. Could you please help out with how I fix this issue.

      regards

      Chris

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.