Skip to Content
author's profile photo Former Member
Former Member

J2ee engine does not start up after system copy

Dear All,

I have done a system copy of BW3.5 (NW04). I installed the BW.3.5 and then replaced the data and control files.

This has ABAP + java.

Now after system copy when i am starting the server, the J2ee instance doesnt start up.

ABAP is running and DB is up too.

I am getting the following error in log_bootstrap file:-

Exception occured:

com.sap.engine.bootstrap.SynchronizationException: Database initialization failed! Check database properties!

at com.sap.engine.bootstrap.Bootstrap.initDatabaseConnection(Bootstrap.java:422)

at com.sap.engine.bootstrap.Bootstrap.<init>(Bootstrap.java:144)

at com.sap.engine.bootstrap.Bootstrap.main(Bootstrap.java:813)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)

at java.lang.reflect.Method.invoke(Method.java:391)

at com.sap.engine.offline.OfflineToolStart.main(OfflineToolStart.java:81)

-


==[ Caused by: ]==----


com.sap.engine.bootstrap.SynchronizationException: No such Dialog Instance (ID1125100) in the database! Check

database consistency or local Bootstrap properties!

at com.sap.engine.bootstrap.Synchronizer.getElementType(Synchronizer.java:81)

at com.sap.engine.bootstrap.Bootstrap.initDatabaseConnection(Bootstrap.java:420)

at com.sap.engine.bootstrap.Bootstrap.<init>(Bootstrap.java:144)

at com.sap.engine.bootstrap.Bootstrap.main(Bootstrap.java:813)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)

at java.lang.reflect.Method.invoke(Method.java:391)

at com.sap.engine.offline.OfflineToolStart.main(OfflineToolStart.java:81)

[Aug 26, 2008 2:00:26 PM ] [Bootstrap module]> Problem occured while performing synchronization.

[Aug 26, 2008 2:00:42 PM ] -


[Aug 26, 2008 2:00:42 PM ] Bootstrap MODE:

[Aug 26, 2008 2:00:42 PM ] <INSTANCE GLOBALS>

[Aug 26, 2008 2:00:42 PM ] determined by parameter [ID0011251].

[Aug 26, 2008 2:00:42 PM ] -


[Aug 26, 2008 2:00:46 PM ] Exception occured:

com.sap.engine.frame.core.configuration.NameNotFoundException: A configuration with the path "cluster_data/di

spatcher/ID1125100" does not exist.

at com.sap.engine.core.configuration.impl.ConfigurationDataCacheAllImpl.getSubConfiguration(Configura

tionDataCacheAllImpl.java:107)

at com.sap.engine.core.configuration.impl.ReadAccessConfiguration.getSubConfiguration(ReadAccessConfi

guration.java:715)

at com.sap.engine.bootstrap.Synchronizer.getConfiguration(Synchronizer.java:365)

at com.sap.engine.bootstrap.Synchronizer.getElementType(Synchronizer.java:78)

at com.sap.engine.bootstrap.Bootstrap.initDatabaseConnection(Bootstrap.java:420)

at com.sap.engine.bootstrap.Bootstrap.<init>(Bootstrap.java:144)

at com.sap.engine.bootstrap.Bootstrap.main(Bootstrap.java:813)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)

at java.lang.reflect.Method.invoke(Method.java:391)

at com.sap.engine.offline.OfflineToolStart.main(OfflineToolStart.java:81)

What could the problem?. Do I need to do some other settings for system copy of JVA instance?

Kindly help

Thanks

Tajinder

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Aug 26, 2008 at 02:17 PM

    Copies of systems containing Java must be done using sapinst. If you didn't do that you need to repeat the copy process.

    The reason is: many configurations are stored on the filesystem of the J2EE engine and also in the database schema of the Java instance. If you copy just the database, those entries don't match and the system won't start.

    --> http://service.sap.com/systemcopy

    Markus

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Markus Doehr

      Hi,

      sorry for so much delay in replying as I had to go for another project.

      I had got that working.

      Now i have several systems copies to make.

      I will look forward to take help from all for you.

      I am closing the thread.

      I am happy to award points to all of u.

      Thanks

      Tajinder

  • author's profile photo Former Member
    Former Member
    Posted on Aug 26, 2008 at 10:54 AM

    Hi,

    "com.sap.engine.bootstrap.SynchronizationException: Database initialization failed! Check database properties!

    at com.sap.engine.bootstrap.Bootstrap.initDatabaseConnection(Bootstrap.java:422)"

    As per the above error, bootstrap fails to synchronize the files from the database and exits with non-zero return code.

    Just check out this note 997510 which will help to diagonise your problem.

    Post us the dev_jcontrol log file so that we can diagonise much more

    Rgds

    Radhakrishna D S

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      After efforts i am able to proceed a bit further.

      i edited the files on OS and through configtool.

      Then came the file missing and synchronization errors.

      I think now i have solved that too. But still there is problem.

      This is what I think my problem is. may be I am wrong. Please do correct me.

      Now the problem is that in my instance.properties file, the data is taken from database. And since my DB is of other server. So it is reading that hostname for mesg server and en. host as of my other server. So j2ee instance is not starting up.

      My jvm_bootstrap_ID***.out has following lines:-

      No local properties available for [ApplicationThreadManager].

      No local properties available for [IpVerificationManager].

      No local properties available for [kernel_shell_commands].

      No local properties available for [LicensingManager].

      No local properties available for [ClassLoaderManager].

      No local properties available for [PoolManager].

      No local properties available for [ThreadManager].

      No local properties available for [LockingManager].

      But it is able to synchronize the files.

      My dev_jcontrol now reads as:-

      Thr 01] *** ERROR => Invalid property value [box.number/BD1DVEBMGS00bwdev] [jstartxx_mt. 789]

      [Thr 01] *** ERROR => Invalid property value [en.host/"hostname"] [jstartxx_mt. 789]

      [Thr 01] *** ERROR => Invalid property value [en.port/3201] [jstartxx_mt. 789]

      [Thr 01] *** ERROR => Invalid property value [system.id/0] [jstartxx_mt. 789]

      And the values for en.host are of the old server.

      I tried to change these from configtool too. But it is not helping. It is showing the new values in configtool. I also changed the values in instance.properties file but they also get changed as the server is restarted.

      So is there any way that we can fix the values in instance.properties file or we can change the values from where it reads?

  • author's profile photo Former Member
    Former Member
    Posted on Sep 21, 2008 at 08:35 AM

    Hi basis guruu2019s

    i am also facing same problem can any one help for the same.

    We are in progress of HADR for EP and we have successfully established the same, both servers are able to sync logs (primary to standby server.)

    For integration (with BI) purpose I separated via stopping HADR on primary and standby, now standby server db is activated .when I am trying to access portal with standby local host name its showing blank page.

    Same time when try to connect visual administrator it will give below error

    u201CUnable to lookup connection defaultu201D

    u2018http://MEPPRD101:8134/msgserver/txt/logon/returned empty list of connection parametersu201D

    Please find below info from dev_ jcontrol log.

    Thr 1] Sat Sep 20 18:21:53 2008[Thr 1] *** WARNING => INFO: Unknown property [instance.box.number=MPPJC33mepprd101] [jstartxx_mt. 840]

    [Thr 1] *** WARNING => INFO: Unknown property [instance.en.host=MEPPRD101] [jstartxx_mt. 840]

    [Thr 1] *** WARNING => INFO: Unknown property [instance.en.port=3234] [jstartxx_mt. 840]

    [Thr 1] *** WARNING => INFO: Unknown property [instance.system.id=33] [jstartxx_mt. 840]

    [Thr 1] *** ERROR => invalid return code of process [bootstrap] (exitcode = 66) [jstartxx_mt. 1641]

    [Thr 1] JControlExecuteBootstrap: error executing bootstrap node [bootstrap] (rc = 66)

    [Thr 1] JControlCloseProgram: started (exitcode = 66)

    [Thr 1] JControlCloseProgram: good bye... (exitcode = 66)

    Thanks in advance

    Regards

    Vijay

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Vijay

      >For integration (with BI) purpose I separated via stopping HADR on primary and standby, now standby server db is activated .when I am trying to access portal with standby local host name its showing blank page.

      Did you install your HADR system using virtual hostnames? In a failover the physical hostname should change, but the virtual hostname should stay the same to avoid issues.

      Best Regards,

      Matt

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.