Skip to Content

X64 java 1.4.2_18 for SAP

Hello Basis. I'm install yesterday new SR3 Netweaver AS JAVA (Portal+BI).

On installation stage I have faced a problem....

OS are Windows x64 -->

System Model: PowerEdge 2950

System Type: x64-based PC

Processor(s): 8 Processor(s) Installed.

EM64T Family 6 Model 15 Stepping 7 GenuineIntel

First i'm download and install J2SE per note Note 941595 - Download J2SE 1.4.2 for the x64 platform

Java SE Development Kit 1.4.2_18 x64 SAP .

On installation stage "Install software units" 32 of 43 -->

installation hangs with message :

"Begin of SAP J2EE Engine Deployment (J2EE Application)"

no errors no other logs , and in sapinst_instdir no files are changed on 3-4 hours ......

I have formatted system, and try NEW installation, install same version of J2SE -->

on this time , installation stops on stage "start java application" , but jcontrol.exe are shutdown after start, from log i'm find the error comes from J2SE, uninstall 1.4.2_18 and install 1.4.2_13 -->

after this installation has proceeded and has ended without errors.

Somebody observed same?

Regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 22, 2008 at 05:53 AM

    You are right buddy ...

    We had few problems with Java 1.4.2.18 for 64 Bit Windows. 1.4.2.13 works fine.

    Right now I don't remember the note number but SAP specified to use 1.4.2.13 rather than 1.4.2.18.

    Cheers!

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 22, 2008 at 05:52 AM

    Dear

    Yes

    You can find the information in SAP note 716604

    Note 716604 - Access to Sun J2SE and recommended J2SE options

    "part of the note:"

    Important note:

    With 1.4.2_18 we are currently having massive stack overflow problems on Windows x86 (64bit) with our default parameter set. The issue is still under investigation. Additionally we have a performance regression with Java Systemcopy on 1.4.2_18.

    Until further notice please don't use 1.4.2_18.

    In the meantime SUN has made available 1.4.2_17 for Windows x86 (64bit) and Solaris x86 (64Bit) for download. Please see note 941595.

    Kind regards

    Tom

    Add comment
    10|10000 characters needed characters exceeded