Skip to Content
author's profile photo Former Member
Former Member

Error executing job

I encountered the following error when running a job with transformation:

'The job to calculate usage dependencies cannot be executed because the job contains obsolete connection information. Please notify Customer Support'

What might be the cause?

Thanks

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 21, 2008 at 04:20 PM

    Hello,

    Can you try following and see if the error goes away?

    Right click on any dataflow in the Local object library and select Repository->"Calculate Usage Dependencies". This may take a while depending on how big your repository is.

    Once this is done, try running the job again.

    Do let us know.

    Thanks,

    Anagha

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 21, 2008 at 10:58 PM

    Background : in every repository there are some hidden jobs that calculate the usage dependencies needed to show impact and lineage information in the management console. These jobs use a (hidden) datastore with the connection to your repository. When you change the repository password at the database level, the connection information in this hidden datastore will not be valid anymore. I'm assuming this is what happend in your case.

    In order to solve this :

    1) Start Designer and go to Tools / Options / Job Server / General

    2) Add the following attribute values to unhide the hidden objects in the repository :

    Section : STRING

    Key : DisplayDIInternalJob

    Value : TRUE

    3) Click OK to close the options window.

    4) Now restart Designer to enforce the new options.

    5) You will see a new datastore with the name CD_DS_d0cafae2. Edit the datastore with the correct connection parameters for your repository.

    6) To hide the datastore again, repeat steps 1-4 but use FALSE as the value.

    Hope this helps. If you search the documentation for "Display DI Internal Job" you will get some more detail (Designer Guide / Executing jobs).

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2008 at 02:50 AM

    I'll try it out. Thanks a lot guys

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 05, 2014 at 02:34 PM

    Appreciate this is a very old post!

    I am using Designer 12.2.3.1 and could not seem to change this option using Designer. Found out that another way was to directly edit DSConfig.txt located on my computer in C:\Program Files\Business Objects\BusinessObjects Data Services\bin\

    The String section did not have a DisplayDIInternalJobs entry so adding DisplayDIInternalJobs=TRUE to the section worked for me.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.