Skip to Content

Issue with Value Mapping while deploying

Hi,

I am getting the following error while deploying the Value mapping artifact. What i am doing is, i have downloaded a standard artifact of value mapping and added some new entries to that VM. I have to make it custom. I have changed the Bundle-SymbolicName and loaded to web UI and changed/added entries. After that i tried to deploy. While starting itself, it is throwing the following error:

Error Details [CONTENT][CONTENT_DEPLOY][ArtifactDeploymentFailed] : All attempts of deployment of artifact failed. Error details: Exception in com.sap.xi.mapping.camel.valmap.ValueMappingActivator.start() of bundle ValueMapping_CRM_to_C4C..
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Mar 21 at 04:55 PM

    Hi Imran,

    There might be a version mismatch or corruption of the value mapping artifact during edit. Please use the webUI application to update the value mapping and deploy. If you would like to use a custom value mapping, please consider creating it from scratch it the webUI application.

    Hope this helps,

    Gayathri

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 21 at 09:43 PM

    Hi Imran,

    To make Standard Value-mapping Artifact to a Custom, Please do the following things and deploy it again.

    1. Change Bundle-SymbolicName

    2. And remove the SAP-ContentMode in the Manifest File.

    And deploy the same content back to tenant.

    Try this, It worked for Me.

    Thanks

    --Siva

    Add comment
    10|10000 characters needed characters exceeded