Skip to Content
0

SAP Webdispatcher not switching from HTTP to HTTPS

Oct 28, 2016 at 10:31 PM

116

avatar image

Hi there,

We have built a new SAP webdispatcher (version 7.45) using sapinst. It is working in regards to connecting to the appropriate backend etc. The only issue I am having is that the redirect is not working properly in changing the protocol from HTTP to HTTPS. If you simply enter the HTTPS:\\URL it will redirect properly, but won't work if you enter the URL with HTTP.

I'm using the webdispatcher administration to do the configuration, as opposed to editing the profile manually. With older versions editing the profile worked and there wasn't an issue, but with the newer version it doesn't seem to work, or I am missing something.

I was hoping someone could help guide me in the right direction to get this piece working properly.

Kind regards,

Chris

webdispatcher.jpg (237.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Tong Ning Oct 31, 2016 at 02:45 AM
0

Check the trace files of Web Dispatcher to see if it is related to the peer certificate problem of HTTPS?

Share
10 |10000 characters needed characters left characters exceeded
Chris Mckay Oct 31, 2016 at 03:02 PM
0

Hi again all,

I ended up answering my own question for this particular issue. After checking everything I noticed the following line: icm/server_port_0=PROT=HTTP,PORT=8100,TIMEOUT=60,PROCTIMEOUT=60

I tested using http://hostname.company.com:8100 and the redirect from HTTP to HTTPS worked perfectly. I tried changing 8100 to just 80 and that caused a new issue that I will create a separate thread for, but just wanted to update that this original issue has been resolved and working as expected.

Share
10 |10000 characters needed characters left characters exceeded