Skip to Content
avatar image
Former Member

Missing Libra Repository?!

Hello there,

trying to start with "Configuring Eclipse with SAP Cloud Platform Tools for Java" today but got the following error message:

"Cannot complete the install because one or more required items could not be found. Software being installed: SAP Cloud Platform Tools for Java 1.86.0 (com.sap.core.tools.eclipse.server.feature.feature.group 1.86.0) Missing requirement: SAP Cloud Platform server adapter commons 1.85.0 (com.sap.core.tools.eclipse.server.common 1.85.0) requires 'bundle org.eclipse.libra.facet 0.0.0' but it could not be found Cannot satisfy dependency: From: SAP Cloud Platform server adapter 1.85.0 (com.sap.core.tools.eclipse.server.cloud.feature.feature.group 1.85.0) To: com.sap.core.tools.eclipse.server.common [1.85.0] Cannot satisfy dependency: From: SAP Cloud Platform Tools for Java 1.86.0 (com.sap.core.tools.eclipse.server.feature.feature.group 1.86.0) To: com.sap.core.tools.eclipse.server.cloud.feature.feature.group [1.85.0]"

Looks like a libra repository is missing?!

Can someone please help me out here.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Mar 19, 2018 at 04:06 PM

    Hi Michel,

    Did you use the correct update site according to the Eclipse version supported?

    Regards,
    Ivan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 29, 2018 at 10:49 AM

    Sometimes also get this error message:
    "An error occurred while collecting items to be installed session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,org.eclipse.emf.transaction,1.9.0.201706061339 No repository found containing: osgi.bundle,org.eclipse.emf.validation,1.8.0.201706061352 No repository found containing: osgi.bundle,org.eclipse.emf.workspace,1.5.1.201706061339 No repository found containing: osgi.bundle,org.eclipse.graphiti,0.14.0.201705161212 No repository found containing: org.eclipse.update.feature,org.eclipse.graphiti.feature,0.14.0.201705161212 No repository found containing: osgi.bundle,org.eclipse.graphiti.mm,0.14.0.201705161212 No repository found containing: osgi.bundle,org.eclipse.graphiti.pattern,0.14.0.201705161212 No repository found containing: osgi.bundle,org.eclipse.graphiti.ui,0.14.0.201705161212 Multiple problems occurred while downloading. Unable to read repository at http://download.eclipse.org/webtools/downloads/drops/R3.8.0/S-3.8.0M6-20160324010110/repository/plugins/org.eclipse.jpt.jpadiagrameditor.branding_1.2.101.v201501141513.jar.pack.gz. Address family not supported by protocol family: connect Unable to read repository at http://download.eclipse.org/webtools/downloads/drops/R3.8.0/S-3.8.0M6-20160324010110/repository/plugins/org.eclipse.jpt.jpadiagrameditor.branding_1.2.101.v201501141513.jar. Address family not supported by protocol family: connect Multiple problems occurred while downloading. Unable to read repository at http://download.eclipse.org/webtools/downloads/drops/R3.8.0/S-3.8.0M6-20160324010110/repository/plugins/org.eclipse.jpt.jpadiagrameditor.doc.user_1.2.101.v201501141513.jar.pack.gz. Address family not supported by protocol family: connect Unable to read repository at http://download.eclipse.org/webtools/downloads/drops/R3.8.0/S-3.8.0M6-20160324010110/repository/plugins/org.eclipse.jpt.jpadiagrameditor.doc.user_1.2.101.v201501141513.jar. Address family not supported by protocol family: connect No repository found containing: org.eclipse.update.feature,org.eclipse.jpt.jpadiagrameditor.feature,1.2.300.v201604110621 No repository found containing: osgi.bundle,org.eclipse.jpt.jpadiagrameditor.ui,1.2.200.v201604110621 No repository found containing: osgi.bundle,org.eclipse.libra.facet,0.3.1.201609011955 No repository found containing: org.eclipse.update.feature,org.eclipse.libra.facet.feature,0.3.1.201609011955 No repository found containing: osgi.bundle,org.eclipse.libra.facet.ui,0.3.1.201609011955"

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 17, 2018 at 06:40 AM

    I has the same error.

    Any know how to solve it?

    Thx.

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 18, 2018 at 07:50 AM

    Hi,

    Could you please try to add the libra update site (http://download.eclipse.org/libra/releases/) and try to install the SAP Cloud Platform Tools for Java again? Let me know the result.


    Best regards,

    Ismail Alidzhikov

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ismail,

      I was also getting same error after adding Libra , that went away and can now install SAP Cloud Platform Tools , but still cannot install the SAP Cloud Platform Integration Tool . Getting below error, can you let me know what would be needed to overcome it ?

      "

      Cannot complete the install because one or more required items could not be found.
      Software being installed: Operations for SAP Cloud Platform Integration 2.45.0 (com.sap.it.op.cockpit.ui.feature.feature.group 2.45.0)
      Missing requirement: SAP Command Framework - HTTPcommunication (apache) 1.47.0 (com.sap.it.commons.command.http.apacheclient 1.47.0) requires 'java.package; org.apache.http.auth [4.1.0,4.5.0)' but it could not be found
      Cannot satisfy dependency:
      From: SAP Integration Technology Commons Eclipse Base 1.24.0 (com.sap.it.commons.command.base.feature.feature.group 1.24.0)
      To: org.eclipse.equinox.p2.iu; com.sap.it.commons.command.http.apacheclient [1.47.0,1.47.0]
      Cannot satisfy dependency:
      From: SAP Integration Operations Base API 2.45.0 (com.sap.it.op.base.feature.feature.group 2.45.0)
      To: org.eclipse.equinox.p2.iu; com.sap.it.commons.command.base.feature.feature.group [1.24.0,1.24.0]
      Cannot satisfy dependency:
      From: Operations for SAP Cloud Platform Integration 2.45.0 (com.sap.it.op.cockpit.ui.feature.feature.group 2.45.0)
      To: org.eclipse.equinox.p2.iu; com.sap.it.op.base.feature.feature.group [2.45.0,2.45.0]"

  • Sep 21, 2018 at 09:26 PM

    Ismail,

    Thanks a lot, it works for me!

    Regards

    Add comment
    10|10000 characters needed characters exceeded