Skip to Content
avatar image
Former Member

SAP Note 830576 - Parameter recommendations for Oracle 10g

As per SAP Note 830576 - Parameter recommendations for Oracle 10g, I have tried to change the value for

parameter "db_file_multiblock_read_count".

In sql prompt it shows:

SQL> show parameter DB_FILE_MULTIBLOCK_READ_COUNT

NAME TYPE VALUE

-


-


-


db_file_multiblock_read_count integer 128

and in brtools it shows:

58 - db_file_multiblock_read_count both no * yes 128

But I got the following error, when i tried to set it null

1 * Parameter description (desc) ..... [db block to be read each IO]

2 * Parameter type (type) ............ [integer]

3 * Current parameter value (parval) . [128]

4 * Value in spfile (spfval) ......... []

5 # New parameter value (value) ...... [null]

6 - Scope for new value (scope) ...... [both]

7 # Database instance (instance) ..... []

8 ~ Comment on update (comment) ...... []

9 - SQL command (command) ............ [alter system reset db_file_multiblock_read_count scope = spfile sid = '*'; alter system reset db_file_multiblock_read_count scope = memory sid = 'MBD']

BR0662I Enter your choice:

c

BR0280I BRSPACE time stamp: 2008-08-14 18.19.22

BR0663I Your choice: 'c'

BR0259I Program execution will be continued...

BR0280I BRSPACE time stamp: 2008-08-14 18.19.23

BR0301E SQL error -32010 at location BrSqlExecute-1, SQL statement:

'/* BRSPACE / alter system reset db_file_multiblock_read_count scope = spfile sid = '''

ORA-32010: cannot find entry to delete in SPFILE

BR1017E Execution of SQL statement 'alter system reset db_file_multiblock_read_count scope = spfile sid = '*'; alter system reset db_file_multiblock_read_count scope = memory sid = 'MBD'' failed

BR0669I Cannot continue due to previous warnings or errors - you can go back to repeat the last action

BR0280I BRSPACE time stamp: 2008-08-14 18.19.23

BR0671I Enter 'b[ack]' to go back, 's[top]' to abort:

Kinldy let me know, what could me wrong.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 14, 2008 at 03:45 PM

    Hi,

    The error is clear:

    > ORA-32010: cannot find entry to delete in SPFILE

    You do not have the parameter set, so it cannot be "reset"

    As the parameter is not set, then it gets its default value.

    That is what you see when you do show or in brtools.

    If you pay attention to the header in brtools you can see

    Pos.  Parameter                          Modif.  Spfile  Inst.    Deft. Value
    58 - db_file_multiblock_read_count       both     no      *       yes   128
    

    you can see how below Spfile you have "no" and below Deft (I think it is default) you have "yes"

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 15, 2008 at 11:24 AM

    Vijay,

    Its correct.

    Even I had faced this issue.

    You cannot change this value. This is default value.

    If u dont get it in spfile, leave it.

    Thanks,

    Anu.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 16, 2008 at 03:35 AM

    Thanks Fidel Vales and Anu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 08, 2009 at 04:00 PM

    Hi Markus,

    As per your suggestion we have downloaded the files from UCLIB_3-20000978.SAR. But now getting the error as

    sapccmsr -DCCMS -j2ee pf=profile value

    INFO: use SAPLOCALHOST hostname

    INFO: CCMS agent sapccmsr working directory is /usr/sap/ccms/XX1_00/sapccmsr

    INFO: CCMS agent sapccmsr config file is /usr/sap/ccms/XX1_00/sapccmsr/csmconf

    INFO: Central Monitoring System is [XX1]. (found in config file)

    INFO: additional Central Monitoring System is [AS2]. (found in config file)

    ERROR: Cannot open Monitoring Segment 0 rtc = 245

    Last reported error: [249] CCMS monitoring segment has wrong EYE CATCH. It seems to be created as non-unicode segment.

    This program runs as unicode. Please use non-unicode version

    Please suggest

    Thanks,

    Anu

    Add comment
    10|10000 characters needed characters exceeded