Skip to Content
0

UWL Tab / WDJ navigation hides predecessor tabs on FLP

Mar 16 at 12:07 PM

61

avatar image
Former Member

Hi,

I have noticed a slight difference in runtime behaviour while navigating in the UWL iView depending on the framework I use. Classic behaves like:

1.)Initial call

2.)Click on alerts

By contrast FLP:

1.)Initial call

2.)Click on alerts

So, FLP hides the "Task" tab as soon Im clicking on "Alerts", we dont want UWL to do that. I checked PCD properties of UWL iView, marketplace, SCN and browser console for comparable issues resp. any hints on the reason why it doesnt work identically on FLP but wasnt able to find anything of value. Does somebody faced this already?

kind regards

c1.png (195.8 kB)
c2.png (52.6 kB)
f1.png (140.6 kB)
f2.png (41.3 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Nick Rankin
Mar 26 at 03:30 PM
0

Hi Don,

In FLP the recommended option is to use the "My Inbox" application which is UI5 based instead.

Best regards,

Nick

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Nick,

thank you, we thought about this but we have decided against it.

However, this is another topic, as mentioned we are not interested in use of "My Inbox", what we currently trying to ensure is UWL WDJ is working analogous in standard framework as well as in classic. What I found out meanwhile:

- this problem isnt UWL specific but also occurs within other WDJ application, even in the NWA

- it seems occurance depends on the rendering mode of the framework, FLP is pushing it into standard, classic does not

Customer decided to patch the Portal using latest available AJAX patch and open an OSS, if the error still should be there. Due my current stand Im strongly assuming its a simple product error: I cant imagine different runtime behaviour within WD applications depending on used rendering mode is "works as designed". If you already ran over a corresponding SAP note or something comparable, please let me know. Thanks,

kind regards

0
Former Member

As already assumed a product error. Solved by patching:

best regards

patch.jpg (15.7 kB)
0