Skip to Content

Custom themes not working after portal upgrade 7.5

Hi,

We have upgraded our portal from 7.3 to 7.5. In WDABAP iViews the url text colors and images are changed. We think this is due to custom themes.

1. We have UI theme designer now in 7.5 and no theme editor In NWA, already we have blank in the property Determine what will be the theme runtime provider, but we are unable to see the Theme Editor. https://archive.sap.com/discussions/thread/3755478

2. We have taken backup before upgarde and have to use our custom theme which was developed in 7.3 How to resolve the issue?

Please guide us as we have checked below blog, not not clear for us on .CSS or .LESS https://blogs.sap.com/2014/04/01/how-to-ui-theme-designer-migration/

Is the CSS checks required in our case?

Thanks & Regards,

Prasad

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Mar 15 at 11:00 AM

    Hi Prasad,

    Please make sure that the latest version of the Theme Designer component is installed. Refer to SAP note ##1852401 for details. Furthermore please update the UR base content by following note ##2574997

    Regards,

    Dharmendra Kumar

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 15 at 03:03 PM

    Hi Dharmendra,

    I'm able to Rebuild the theme in UI theme designer, but my changes to colors and text which are in 7.3 are not reflecting in 7.5.

    I tried to Edit and "save as" giving below error,

    sap.file.common.MultiFileException:MultiFileException containing exceptions: sap.file.common.HttpRequestException:Failed requesting "https://ggg/irj/servlet/prt/prtrw/prtroot/com.sap.portal.theming.webdav.themeswebdavlistener.ThemesWebDavListener/Portal/AFP/Test". while asynchronously requesting "https://ggg/irj/servlet/prt/prtrw/prtroot/com.sap.portal.theming.webdav.themeswebdavlistener.ThemesWebDavListener/Portal/AFP/Test" with method "COPY" resulting in status code "500"

    Thanks & Regards,

    Prasad

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Prasad,

      Make sure permissions on your file system are good. If you use Change Recording functionality in Portal, please disable it before you try and rebuild you theme.

      Best regards,

      Nick