Skip to Content
avatar image
Former Member

Problems with Oracle JDBC

Hi we are trying to connect to a Oracle 8.1.7 Database using JDBC via XMII 12.04

We have deployed Oracle JDBC ojdbc14.jar

I have set up this connection

Connector IDBC

ConnectorID

ConnectorType SQL

DatePrefix TO_DATE('

DateSuffix ','MM/DD/YYYY HH24:MI:SS')"

DaysRetention 7

Description BIT_ORA

Enabled T

InitCommand

InternalDateFormat MM/dd/yyyy HH:mm:ss

JDBCDriver oracle.jdbc.driver.OracleDriver

MaxRetryCount 5

Name ConectorBIT

PoolMax 100

PoolSize 1

RetryInterval 60000

ServerPackage com.lighthammer.Illuminator.connectors.IDBC

ServerURL jdbc:oracle:thin:@host.domain.com:1521:DBSID

Timeout 15

UseCount 256

UserName pruebas

ValidationQuery SELECT SYSDATE FROM DUAL

WaitTime 30

When I try to see the status I get this

Server Name ConectorBIT

Connector Type SQL

Status *Running*

No. of Used Connections

No. of Available Connections

Max. No. of Used Connections

Max. Wait Time

As you can see it says running but no connections are available.

When I investigate the xapps-xmii-ear apps logs I get the following warning and infos

info 2008-08-12 16:56:08:590 Created Connection pool [

warning 2008-08-12 16:56:08:590 Unable to fill connection pool for /Applications/XMII

warning 2008-08-12 16:56:07:621 Unable to detemermine maximum number of connections from JDBC driver

So somethings wrong. We cannot make a select to the oracle database.

Please advise.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 12, 2008 at 08:36 PM

    Daniel,

    did you realy have the ServerPackage com.lighthammer.Illuminator.connectors.IDBC ?

    In MII 12.0.4 the ServerPackage is com.sap.xmii.Illuminator.connectors.IDBC.

    Please create a new Data Server and select IDBC. Do not modify the ServerPackage.

    Configure the Data Server as you know and test it.

    Let me know.

    Pedro

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Michael,

      try to connect from your MII Server with ojdbc14.jar to any Oracle (Version 9 or 10). Only

      to see if its working or not.

      Good Luck.

      Pedro

  • avatar image
    Former Member
    Aug 15, 2008 at 12:55 PM

    My case was solved with a conbination of things

    First the JDBC driver was wrong

    Download classes12.jar from this link version 10.2.0.4

    [http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/htdocs/jdbc_10201.html]

    Then be carefull when you set up the string because some oracle databases have servicenames instead of SID, and the url was different if you use them instead of the SID

    I found out which was our SID and it worked for us.

    For services names the url changes to jdbc:oracle:thin@//host:port/servicename

    But I coudnt get it working so we finally used the sid.

    To know which oracle jdbc you need , depends which JDK your oracle engines uses, mine was using old JDK 1.1 , so I used classes12.jar.

    IF you have JDK 1.4 and above continue using your oracle14 driver.

    Hope it helps.

    Regards

    Add comment
    10|10000 characters needed characters exceeded