Skip to Content

writing text with special characters to file leads to strange symbols

Hello,

We have an issue with writing special diacritic characters like 'ë' to a file on disk.

The special characters are converted to different format in the file: for instance an 'ë' in SAP becomes 'ë' in the file.

We use the following stametent to create the file:

"Open dataset P_FILE for output in textmode encoding default"

Instead of default we also tried the encoding UTF-8 parameter, but got the same result. Our system is an ERP 6.0 NW2004S system with oracle 10 installed in UNICODE UTF-8.

I also notice that browsing the file in SAP for instance in AL11 shows the right characters. When opening the file outside SAP (in our case AIX) the strange characters are shown. We transfer the files with XCOM, so this is a big problem.

Regards,

Jurgen Meulenbeek

ING

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Aug 12, 2008 at 08:37 AM

    Hi Jurgen,

    everything is ok. You get the ASCII representation of your character. In an ASCII editor the UTF-8 character 'ë' is displayed as 'ë'. You have to use an Unicode editor to view the correct character. If you copy the file to Windows and open it with Word or even Notepad (if your OS is new enough), then you should get the correct output. I don't know which editor on AIX supports UTF-8, but there is probably also an editor there for Unicode.

    Regards

    Ralph

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.