Skip to Content
author's profile photo Former Member
Former Member

Background Job

Hello Frineds,

Currently I am working on SCM 5.0 Version.

Actually scenario is like that,I have created one Time Series Key figure i.e Stock for SNP planning area & i want to copy Stock on hand key figure(Aux. key fig.) which is std. one to Time series Stock Key figure through Macro.After that i run the Transaction /n/sapapo/tscopy for Copy Stock key figure data from SNP to DP Key fig.I have tried to execute Macro through Default condition,but if i put macro in Default,Macro work Properly but Copy transaction not working Properly.Data of Both Stock key fig. in SNP & DP is different.

So i have switch macro to manualy execution mode,but if i run macro at Aggregated level,detail level value found equal & if i tried to run at Detail level,but system will take so muchn time (More than 15-20 min.) to switch at detail level.becz i have more than 400 product in selection ID in SNP planning Area.This option is ok if there is 20-30 product only.

So i tried to run macro in Background Job.for that i have created Activity,then assign this activity to Job.In Job system automatically select Aggregation level according to Selection ID(i.e. 9amalo---9alocno & 9amatnr).So when i run the job in background i found log "Macro Stock has been executed & No data has been changed,data must not saved." After that when i am looking in to Planning book there is no one value found in Stock key figure.

So i could not able to SNP stock time series key figure to Stock DP time series key figure.

Can anyone suggest me solution?

Thanks in Advance!!!!!!!!

Regards

Sujay

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Aug 09, 2008 at 10:28 PM

    Hi Sujay,

    The whole thing looks like you are not doing it at the right aggregation level.

    The other question that pops up when you say "if i put macro in Default,Macro work Properly but Copy transaction not working Properly", is the copy function between keyfigures that you used in not working or do you have TSCOPY in the macro??

    Were you at the same level when you executed the macro in default and when you executed the background job??

    In MC8E, you have to specify the aggregation level. If your macro is designed to work at a particular level of detail and if you donot specify the same level in job, it gets executed successfully.

    Eg: You have location, product and sales area as characteristics and in your macro, you defined saying

    If Drill_down(plant) = 1 and Drill_down(location) = 1 and Drill_down(sales area) = 1, then copy KF to KF2.

    If in your background job, in aggregation, you check only location and product, as the condition in macro is not satisfied, the macro doesnot get executed but the job gets completed successfully.

    Successful execution of a background job mean successful system execution but not the macro execution.

    Also in the same MC8E- job change, you have the check box "generate log". If you check this and runt he job, you can got to MC8K and check the detailed logs.

    I am assuming you have done the job creation basics like executing in the same planning book, data view, version etc..

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.