Skip to Content
0

Deactivate REDOLOG_FILE_MIRROR on a AS Java with oracle

Mar 13 at 01:00 PM

48

avatar image

Good afternoon,

We have installed a Solman 7.2.

The DB has been installed without log mirroring.

brconnect -u // -c -f check complains for the following.

BR0970W Database administration alert - level: ERROR, type: REDOLOG_FILE_MIRROR

With an Abap AS, I can disable this check from db17 transaction.

How can I disable this check in a Java AS?

Have a good day.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Prithviraj Rajpurohit Mar 13 at 03:40 PM
0

Hi,

Please try setting value N in initSID.sap file for the parameter REDOLOG_FILE_MIRROR

"DBA:REDOLOG_FILE_MIRROR:N:E::::",

for more information check

892294 - Enhanced support for non-ABAP database in BRCONNECT 7.00

Hope that helps.

Regards,

Prithviraj

Share
10 |10000 characters needed characters left characters exceeded
James Zhang
Mar 14 at 12:00 AM
0

As Prithviraj answered, you can adapt brtools parameter file, or you can adapt control table DBCHECKORA, the same as db17, please check whether you can this table in your java stack.

If there is, then use sql to update it:

update DBCHECKORA set ACTIVE='N' where PARAM='REDOLOG_FILE_MIRROR';
commit;

Share
10 |10000 characters needed characters left characters exceeded
Benoît Schmid Mar 14 at 07:54 AM
0

Hello Prithvirajr,

Settings the following in initSID.sap works.

check_cond = ("DBA:REDOLOG_FILE_MIRROR:N:E::::")

Thanks

Share
10 |10000 characters needed characters left characters exceeded
Benoît Schmid Mar 14 at 07:55 AM
0

Hello James,

Thanks for your suggestion. I did not know that it was so easy to modify it in the DB.

But I prefer not modifying directly the DB because it is not supported by SAP.

Regards.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

yes, your concern makes sense, so adapting brtools parameter has no such risk

0