Skip to Content
0

Problem Importing HANA Schema From one server to another

Mar 12 at 05:15 PM

59

avatar image
Former Member

Hi all,

i'm experiencing problems importing HANA schema from one server to another server.

Both server have the same HANA Version 1.00.122.05.

I exported schema and data from first server from Hana Studio.

Now i'm trying to import schema in my test environment using import function of Hana Studio, but i'm gettng the following error.

Anyone has some hint? I've searched in SCN for similar error, but didn't find a solution.

I had similar error with another database schema too...it's not possible that should be so problematic export and import a schema from one server to another! In SQL Server it takes not more than 2 minutes without any problem!

10 |10000 characters needed characters left characters exceeded

A schema export/import is not a backup/restore!

0
Former Member

I know, just typed wrong because i was in hurry.

Just wanted to say that can't be so problematic export and import a schema from database to another having the same appliance version.

By the way this post doesn't answer to my question....have you got any hint?

How can i have import a schema from one database to another for developing and testing purpose?

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
avatar image
Former Member Mar 14 at 09:02 AM
0

Solved.

Had to import launching SQL statement for import because import from HANA Studio right clicking on catalogs and choosing "Import..." doesn't work.

Share
10 |10000 characters needed characters left characters exceeded
Pratik Kasralikar Mar 12 at 06:19 PM
0

Check whether import happened correctly or not. There maybe possibility that Schema's are not properly imported from one server to other.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Of course the schema has not been imported, or i wouldn't have asked for some hint.

Have you got any hint?

0