Skip to Content
avatar image
Former Member

Connect to CRM system via Visual Composer

I have created a new SAP_CRM connection in my portal landscape and trying to retrieve some data via VC from my SAP_CRM connection. When I click on Find data in my VC I get the error "failed to connect to backend system. Check your system definition and user privileges".

If I perform a "connection test" in my portal I get the error that "An HTTP/S connection to http://ncdapp22.esc.win.colpal.com:8022/sap was not obtained successfully; this might be due to a closed port on the Firewall.".

I'm not too sure how to trouble shoot this one. I've read a few posts on SDN saying that I should try to disable the firewall but I don't have access to the CRM server to do so. Is there anything else I could check? Also, I have created an Iview which points to a BSP in my SAP_CRM system. This iview works fine in that it retireves my data from SAP_CRM. Its just that I can't connect to SAP_CRM via VC. PLEASE HELP!!!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Aug 07, 2008 at 07:51 AM

    Hi Vincent,

    You will get this error when there is no UserMapping to the CRM System for the user you have logged in to VC. For doing the user mapping you should follow the follwing steps-

    -Open the System You have created

    -in the 'Property Category' select 'UserManagement'

    -Select Usermapping type as 'user,admin'.

    -Save the system.

    -Now go to Usermanagement

    -Give the Username to which u need to do mapping in Idendity management

    -Select the user and select modify

    -Select usermapping for system acess tab.

    from the dropdown select the system u have created

    -At the bottom give the username and password to that backend system

    This will solve you problem.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Raju,

      I am facing same issue

      error msg :

      An HTTP/S connection to http://NW04SBI7.test.com:8000/sap/bc/gui/sap/its/webgui was not obtained successfully; this might be due to a closed port on the Firewall.

      How to solve this issue?

      I tried following the steps you mensioned but i can't find

      any thing like identity management under user administration.

      Thanks in Advance.

      Regards,

      Raghu.

      Edited by: Raghu tej harish reddy on Sep 11, 2008 2:03 PM